64gb Cruicial M4 raid 0, Underperforming and not sure why


Feb 3, 2012
Hi there,

Edit: Upon further reading, it seems since I am now running the raid in sata II the speeds that I am getting am normal. Now I am back to the question as to why I kept getting blue screens when using sata III Marvell ports/drivers?

First time doing a raid setup here and basically after looking up others results for the numbers that I should be getting I believe that my drives are massively under performing. So heres the story, I got one 64gb crucial m4 a few months back and got another one a few days ago. I talked to some people and I decided raid 0 was the best option for me. I read some forums, watched some videos and decided to jump right in to try it. I installed both of the ssd's in 6gb/s Marvell ports and set up the raid in the bios (which was easier than I thought it would be). I then proceeded to install windows and everything was running smoothly, shortly after windows installed and I installed the motherboard drivers, the blue screens started happening. Each one giving me the same error "Interrupt Exception Not Handled" and at the bottom of the BSOD was my driver name. I have now switched each SSD to a 3gb/s Intel port, re installed windows 7 and installed the latest Intel rapid storage software. So far no blue screens and everything seems to be running just fine, however I downloaded "AS SSD Benchmark" and found the results to be about half of what others were getting (will post a picture below) and I am not sure why. Any suggesting are more than welcome, like I said, I am far from knowing what I'm doing when it comes to raiding drives.

Some relevant information:
-Firmware of both drives is the same 0009
-Stripe size 128kb

Individual drive speed taken from Newegg:
-Sustained Sequential Read: Up to 500 MB/s (SATA 6Gb/s)
-Sustained Sequential Write: Up to 95 MB/s (SATA 6Gb/s)

System Specs:

Intel Core i7 960
8 GB G.Skill Memory
MSI 560 TI Video Card
2xCrucial m4 Attempting Raid 0
1x640gb WD Blue
1x1TB Seagate drive
MSI X58A-GD45 Mobo
Windows 7 Pro

I don’t know why you’re getting BSOD when your RAID array is on the Marvell ports but even if it worked perfectly your AS-SSD benchmark results would be lower than they are on the Intel 3Gb/s ports.

The maximum data bandwidth of the Marvell 9128 controller is PCIe x1 at 5Gb/s (500 MB/s).
The controller was originally designed to RAID HDDs and 1st generation SSDs.
It can’t handle the speeds of 3rd generation SSDs.

If you were going to use your SSDs as separate drives then connecting them to the Marvell ports will give you better performance than the SATA 2 ports.
But for RAID it’s best you leave them where they’re at.

The advertised 500 MB/s Read and 95 MB/s Write speeds are with Iometer benchmark software. You need to use that software to see how your RAID is performing.