6870 CrossfireX Heaven Unigine benchmark issue

rage33

Distinguished
Apr 18, 2010
466
1
18,860
Hello fellow Toms forum members,

I was just curious if anyone else noticed a significant performance hit on Unigine Heaven benchmark after installing AMD 11.10 drivers. I'm running two HD 6870's in crossfire and just for pure curiosity I decided to run the benchmark to compare scores from my previous benchmark with the same settings. I was rather shocked to find my score had almost cut in half.

I ran the first benchmark back in February '11 and had a minimum FPS of 58.7 and a max of 106. The last benchmark yielded a disappointing minimum FPS of 36.7 and a Max of 59. It should be noted that I have noticed no loss of performance in any real world game play but I just curious if anyone else had experienced this type of behavior as well. Should I just uninstall Unigine and reinstall a fresh program?




Thanks,

Rage33
 

rage33

Distinguished
Apr 18, 2010
466
1
18,860
Yeah, I was sure to set everything exactly the same.

1920X1080
Tessellation: Normal
AA: X4
AF: X16
Fullscreen

Would my monitor have anything to do with it? I was using a HDTV still at 1080P but now I'm using a 24" 1080P LED computer monitor. I can't see why that would effect anything but you never know.
 

gmcizzle

Distinguished
Mar 20, 2009
944
0
19,160
If one driver gives massive performance over another then I would guess there is a slightly different GPU synchronization algorithm at work, in which one may give lower frame rates but reduce micro-stutter, etc. This is just pure speculation though, it could be something totally different.
 

rage33

Distinguished
Apr 18, 2010
466
1
18,860
Okay, so I uninstalled Unigine v2.1 and installed the new v2.5. That seemed to do the trick as far as getting much much better scores. I'm assuming that the old version of Unigine Heaven was originally written for older AMD graphic drivers and the newer version was more compatible with the updated drivers.