Question 6TB external hard drive keeps getting unallocated

Jun 5, 2020
6
0
10
0
I recently bought a WD Black 6TB Performance Internal Hard Drive:

https://www.amazon.com/gp/product/B0792GSD6N/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&th=1

And it keeps getting unallocated when I turn the external HDD hub on or off (although sometimes it doesn't get unallocated), so it no longer shows up in windows explorer and is shown as unallocated in disk management. I am using a two slot Inateck external HDD hub:

https://www.amazon.com/gp/product/B00N1KXE9K/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&th=1

The Amazon details says it supports up to two 10TB drives, so I don't think the hub is an issue. I have another 3TB HDD that is in the external HDD hub which always works whenever I turn the external HDD hub on or off.

Is the hard drive faulty or is there something else that is happening? Or am I not supposed to press the power button before shutting down my computer?
 
Can you show us the Partitions window in DMDE when this happens?

There have been several threads which report a similar issue. There is an easy fix with DMDE which involves a few clicks. An examination of sector 0 may provide some clues.
 
Jun 5, 2020
6
0
10
0
Can you show us the Partitions window in DMDE when this happens?

There have been several threads which report a similar issue. There is an easy fix with DMDE which involves a few clicks. An examination of sector 0 may provide some clues.
Should I do a partition recovery first before running DMDE? I am currently running partition recovery, I can cancel and run DMDE if I should run DMDE while the HDD is still unallocated.
 
DMDE is very simple. It will find your missing partition in a matter of seconds. I wouldn't bother with any other tool. I'll walk you through it.

DMDE will also show us the content of sector 0. That will help us to determine if you are experiencing the same problem reported by others.
 
Jun 5, 2020
6
0
10
0
DMDE is very simple. It will find your missing partition in a matter of seconds. I wouldn't bother with any other tool. I'll walk you through it.

DMDE will also show us the content of sector 0. That will help us to determine if you are experiencing the same problem reported by others.
How do I navigate to the the partitioning window you want to see?

I have attached four images, not sure if they are what you want.







 
Last edited:
R-click the "WDBlack6TB" partition and select "Insert the partition (Undelete)". Then Apply changes and eject and reconnect the USB drive.

Edit:

Before doing the above, double-click the "WDBlack6TB" partition and expand the $Root. Do you see your file/folder structure? If so, then insert the partition, as above.
 
Jun 5, 2020
6
0
10
0
R-click the "WDBlack6TB" partition and select "Insert the partition (Undelete)". Then Apply changes and eject and reconnect the USB drive.

Edit:

Before doing the above, double-click the "WDBlack6TB" partition and expand the $Root. Do you see your file/folder structure? If so, then insert the partition, as above.
Yea that is my partition, I only have one in that drive. After clicking Apply, it says "Do you wish to write changes to disk?" and the default selected option is "No". Should I click "Yes"? There is a warning saying "A system may destroy user data if there are FS errors...".
 

ASK THE COMMUNITY

TRENDING THREADS