Jan 11, 2013
Just yesterday I received my 1gb XFX-7850 in the mail and install went fine, I tried it out on many of my newer, more demanding games and it worked better than I could have hoped.

However issues arose when I started trying to play older and less demanding games, namely Bioshock and Batman Arkham Asylum.

Upon trying to run the game it loads to the menu normally, but from there one of two things will happen
a. The screen will go black, however if I move the mouse around I can still hear mouse over sounds and such so I know that the game itself isn't crashing.
b. I'll get a trail of repeating images following any movement onscreen until eventually it becomes so cluttered only remnants of motion are visible

During troubleshooting it seems that the issue is confined to games running with Direct X 9 since the same problem occurs in the dx9 mode of Saint's Row: The Third, but not in the dx10/11 mode.

I have already cleared drivers and re-installed as well as going into windowed mode and tweaking as many graphics settings as possible.

Any directioning on how to fix the issue would be greatly appreciated.



- Try uninstalling your drivers using these steps

- Reinstall driver again. Download directly from AMD website

- Update DirectX.