7970 Throttling Problem

drmurda

Honorable
May 6, 2012
8
0
10,510
0
So I recently received this Asus 7970 -


http://www.newegg.com/Product/Product.aspx?Item=N82E16814121560

I used GPU Tweak for awhile because it what came with the card, But Im now using good olds MSI Afterburner now because GPU Tweak doesn't let you over volt the gpu enough, And it seemed to throttle the gpu during gaming.

But today when I was testing BF3, MSi Afterburner said my core clock was only 501... My overclock was set to 1Ghz, FFS! And Yes the GPU usage was at 100% the whole time.

I know the 7970s are new and drivers are coming blah bla blah, But is there anyway I can over ride this throttling B.S? :pfff:
 

drmurda

Honorable
May 6, 2012
8
0
10,510
0
Yep, Ive been playing after games and it still does it. I switched the BIOS on the card to see if the second one would work any better.. but it hasent. Its like I paid for a Viper and got a Honda CRX... Ty Asus...
 
If you look at the first tab in MSI Afterburners settings (it may only be in the Beta version), you'll see "Power Control Properties" at the bottom. That allows your card to draw more power than the PCIe spec normally allows. In the CCC, if you overclock there, there is also a PowerTune setting that does the same thing.

Assuming you have a PSU that can handle the extra stress put on it, you will not be throttled if you increase the percentage.
 
The throttling "problem" is now something that Nvidia owners have to be aware of now as well. The 680 at least, now does the same throttling when you draw more power than the PCIe spec allows. Both have a power tuning option to limit this "problem" and allow for the cards to draw more.
 

HuntTheShunt

Distinguished
Jan 31, 2012
32
0
18,530
0

Someone warned me of that so I bought the Gigabyte Windforce instead.
 

drmurda

Honorable
May 6, 2012
8
0
10,510
0
:( Thank you all for the replies... I was going to wait for the MSI Lightning to re-stock, but I couldint wait...

I havent had a temp issue so far, just this and maybe a driver issue with dead space.
 

Similar threads


ASK THE COMMUNITY