• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

7970 Voltage Dropping Under Load

Spacekiwi

Distinguished
Dec 24, 2011
17
0
18,510
0
I recently tried to over clock my HD7970 and suffered from instability even at the 1000MHz over clock recommended on the box. It was seemingly stable in Kombustor however I had artifacts in games. I reset to stock clock speeds and checked GPU-Z under load and noticed that 12V and VDDC dropped significantly.

(12V:12.22-12.16 VDDC:1.039-0.984)

Should I try RMA the card, is there something I can do to fix this issue or is this normal?

Hardware specs:
CPU: Intel i5 750
Power Supply: Seasonic M12 II 750W
Motherboard: GIGABYTE P55M-UD2
Graphics Card: Sapphire HD 7970 Dual X 3GB
Memory: 8GB G.Skill Ripjaws
 

Spacekiwi

Distinguished
Dec 24, 2011
17
0
18,510
0
Yes under load the card has Vdroop, I tried it on a different computer and the voltage increased under load but was still well under what it should be.
 

Spacekiwi

Distinguished
Dec 24, 2011
17
0
18,510
0


I Tried reinstalling drivers and it did not help (On guild wars 2 with overclock at 1000MHz game would constantly crash giving me error something along the lines of AMD driver stopped working and successfully recovered, which made me try re install to see if it would fix).

My PSU was purchased in December 2012 so should be fine, but I cannot rule out that it might be faulty. However I did try my Card in another computer with a different PSU and it had similar problems. If you know a way I can test my PSU to rule it out as a problem please let me know
 

Spacekiwi

Distinguished
Dec 24, 2011
17
0
18,510
0


Yes but under load the VDDC increased in the different system. However it was still well under what it should be
 

Spacekiwi

Distinguished
Dec 24, 2011
17
0
18,510
0


Sadly borrowing his PSU is not an option. And yes the problems are different in the different systems.

In my system when the video card is under load the voltage drops lower than what it was at idle.
In my friends system the voltage increases under load like its meant to, however it is still well under what the voltage should be
 

Spacekiwi

Distinguished
Dec 24, 2011
17
0
18,510
0
Sapphire support is being fairly useless at the moment :(

My last response from them was:
Dear Sir
Try use our new Trixx tool and try again.
Regards

Obviously they are taking my complaint seriously... :pfff:

Edit: I also linked him some pictures trying to more clearly illustrate my problems. Hopefully some members of this forum will have a better time identifying it than the top quality support team at sapphire. http://imgur.com/a/2ocRQ
 

rdc85

Honorable
Apr 29, 2012
2,943
0
13,460
218
The problems with support center now-days, they are more marketing or consumer relation officer (with minimum knowledge) than an technician / engineer...

sad reality....

back to topic...

try reset the clock setting as vanilla card (amd default) setting...

core @925MHz memory @1375MHz see if the artifact still happen....

if the artifact is gone in low clock and only happen when O.C. it could be bad factory O.C. profile....
if the card u bought was O.C. version and not stable out of box (as the labels indicate) I think u had the right to replace the card, or u can override the O.C. profile and try to find the stable clock by yourself.....
 

Spacekiwi

Distinguished
Dec 24, 2011
17
0
18,510
0


I have done some more testing and noticed that if I overclock my card at all (even just a 10MHz increase) I get artifacting issues etc. then when I reset to default values (950MHz or even lower them to 925MHz and lower memory to 1375 like you recommended) I still have artifacting issues etc.
Then when I reboot (with settings at stock values) the card works fine again.

I don't think its an O.C. Card here is a picture of the box: http://imgur.com/a/oYIGk
 

Similar threads