8 GB of Fully Working RAM, BIOS and Windows 8.1 64 Bit only let me use 4/3.9?

Demuny

Honorable
Jul 19, 2013
242
0
10,680
0
Hey.
I've had this issue since last night. I have 2 sticks of 4 GB of DDR3 RAM, adding up to 8, in my motherboard. Before I installed Windows 8.1 64 Bit, the BIOS says that I have 4 GB. When I look in the BIOS, I checked the RAM settings, it says in slot 1 (DIMM 1) there is a 4 gb stick, and in slot 3 (DIMM 3) there is a 4gb stick. I also checked my system info in Windows when I installed it, and it says 8gb (3.9 usable). My brother finished building his pc not long ago, and he had no problem. I also noticed that his BIOS version is 1503, when mine is 0906 (UEFI BIOS). My mobo is ASUS M5A97 LE R2.0. This is also an RMAed motherboard, if that possibly has to do with anything. Any help?
 

RealBeast

Titan
Moderator
Sep 13, 2010
14,803
0
87,210
3,054
It could be a bios issue, there have been a ton on new ones out since yours, update to the latest (2103). Also make sure that both sticks are fully seated.
 

Demuny

Honorable
Jul 19, 2013
242
0
10,680
0

Do I do a direct install from 0906 to 2103, or do I have to go from oldest to newest each?
 

RealBeast

Titan
Moderator
Sep 13, 2010
14,803
0
87,210
3,054


Direct upgrade to 2103, no intermediate flashes needed.

 

Demuny

Honorable
Jul 19, 2013
242
0
10,680
0

Alright. One last question... would there be any risks? I've heard about some dangerous risks in updating a bios.
Also...
I tried updating the BIOS before... and when I get the .CAP file from the ASUS website, I load up EZ Flash 2. I select the file, hit enter, and it says "Selected file is not an EFI BIOS!". I'm a bit confused from this point, this has also been a problem since last night.
 

RealBeast

Titan
Moderator
Sep 13, 2010
14,803
0
87,210
3,054
No danger as long as the power doesn't go out in the middle of the process.

Try updating it in DOS mode like THIS.
 

Similar threads