Question 8700K 90 Degrees Celsius in BIOS with X62

Jun 8, 2019
2
0
10
0
Hey, hows everyone's night / day going.

Hopefully someone experienced might be able to help me troubleshoot my issue as I am a big noob.

So tonight I decided to setup a push pull config on my X62 with another pair of Aer P 140 fans I got from NZXT, installing these went all good except for a small crack in one of the corners from screwing them down to tightly but nothing bad. However, I noticed the radiator had a large dust build up and my dad insisted that we clean it, he suggested to use a vacuum and I know for live electronics this is a big NO but since it was only the radiator I figured it would be fine.

I also got some Thermal Grizzly Kryonaut paste. When I was cleaning the CPU with alcohol wipes, I let back the retention arm to try and remove the excess paste around the IHS, unfortunately in doing so the CPU moved a tiny bit and bent one of the socket pins which is pretty flush to the bottom of the socket, it didnt cause any boot issues though (heres a diagram of which one was bent: View: https://imgur.com/a/POVV2kw
).

I made sure the blocks screws were secure, I put a little too much paste on and figured that was the issue, reapplied with less and still had insanely high temps. When booting I noticed the AIO was making a weird sound (
View: https://www.youtube.com/watch?v=TNPQOHNM7Kk
) but thought it was just the liquid being flushed through the system to recover from reseating the block. I tried some MX4 paste with the X62 still no solution

I happen to have a Hyper 212 EVO, so I decided to try it and boom. No temp issues, booted into Windows fine and currently typing this on my PC.

I just dont understand how my AIO could fail so sporadically as it was working before I pulled my computer apart and I surely don't think vacuuming the radiator would have been the cause.


So to sum up

- Should I try installing the X62 once more, if it fails should I RMA it?

- In regards to the bent CPU socket pin, should I even try to fix it since its flush to the bottom and Windows works anyway? The only issue I see is that in Core Temp I can't see the voltage of my CPU ( View: https://imgur.com/a/hqQZag1
), this could possibly be due to resetting BIOS to default. Previously I had a 4.7GHz @ 1.25v with 3 AVX offset OC running.

Thanks,
Thomas
 

ASK THE COMMUNITY

TRENDING THREADS