Question 89% Memory usage but only 18gb used out of 64gb with pictures! Help needed

Oct 16, 2019
10
0
10
0
Hardware gods please share some light.
I'm running on 16gb x 4 rams (Total 64gb ddr4 3200mhz rams)
Just by counting the ram usage in my processes, ill give take 20GB> ram being used. So i have like 44GB extra or so.
Why is my memory % so high? Previously i was only using probably 50-60% which my computer still runs smoothly. Just recently i keep getting such high memory usage and i cant work properly.
Planning to upgrade to threadripper with 128gb rams but i have to make do with this computer.

Please dont ask me why are there so many tabs running because i run multiple ebay accounts so i cant close them.
Please do advise what is the issue or is there a quick fix?
 
Oct 16, 2019
10
0
10
0
The first thing that HW monitor is showing is that you have 32GB that is hardware reserved. That means that all your DIMMs probably aren't playing nice. You effectively only have 32GB of RAM not 64GB.
Is there anyway i can get them to work together? I'm currently using
Crucial Ballistix Sport LT 3200 MHz DDR4 DRAM Desktop Gaming Memory Kit 64GB (16GBx4) CL16 BLS4K16G4D32AESB (Gray)
Came in a full set off amazon for rams

Mobo - MSI X470 Gaming plus
CPU - Ryzen 2700x
GPU - 1080
xmp/docp i'm not sure, im running all stock because i'm computer stupid and have never tried to overclock because i dont know how haha
 
Oct 16, 2019
10
0
10
0
Is there anyway i can get them to work together? I'm currently using
Crucial Ballistix Sport LT 3200 MHz DDR4 DRAM Desktop Gaming Memory Kit 64GB (16GBx4) CL16 BLS4K16G4D32AESB (Gray)

Came in a full set off amazon
Does the BIOS show them as 64GB? Are you trying to run them at default speed or at XMP (DOCP in AMD world) ?
I'll restart and go into bios and snap a picture rn! thanks guys
 
Oct 16, 2019
10
0
10
0
Does the BIOS show them as 64GB? Are you trying to run them at default speed or at XMP (DOCP in AMD world) ?
32GB hardware reserve.
it mean it not working properly.
full system spec? need exact model of motherboard/ram
for the 4x16GB a kit or 2 different kit?
running xmp/docp profile?
Did i screw something up? its all stock
KILL ME i have been using this setup for 8 months and i thought i was utilizing its maximum LOL!
 
Oct 16, 2019
10
0
10
0
You could shuffle the 4 DIMMs to see if it changes anything. But you might have an actual HW problem with DIMMs. Since you bought all 4 as a set, you would have to return all 4 to get the manufacturer to RMA them.
I talked to crucial and they told me to test 1 ram at a time with different slots.
I did that and all rams were working, the problem is when i reached 48gb, my computer only recognizes 32gb and when i add till 64gb only 32gb shown..... this is killing me
 
Often lower ram speeds and/or relaxed timings must occur if populating 4 sticks..

If that does not help, perhaps a BIOS/RAM issue with more than 32 GB...;look at the mainboard's 'approved/tested' RAM compatibility list....(perhaps yours, although a 'brand name' might not fly with that MB and that CPU...today)
 

Encryption+

Proper
Sep 26, 2019
182
37
140
8
I suspect that the issue is your computer simply doesn't support more than 32 GB of RAM since the behavior your describing is a textbook case of it. If you tell us the specs of your computer/motherboard we can confirm if this is true.
 

kanewolf

Titan
Moderator
I suspect that the issue is your computer simply doesn't support more than 32 GB of RAM since the behavior your describing is a textbook case of it. If you tell us the specs of your computer/motherboard we can confirm if this is true.
Looking at the BIOS pictures you can see it is an X470 Gaming Plus which according to the spec page supports 64GB. There are 9 BIOS versions newer than the A4 version shown on the BIOS screen pictures. A series of BIOS updates might help the 64GB problems. Several posts ago you said you were going to update the BIOS. Which version did you update to?
 
Oct 16, 2019
10
0
10
0
Looking at the BIOS pictures you can see it is an X470 Gaming Plus which according to the spec page supports 64GB. There are 9 BIOS versions newer than the A4 version shown on the BIOS screen pictures. A series of BIOS updates might help the 64GB problems. Several posts ago you said you were going to update the BIOS. Which version did you update to?
I updated to the most recent one, latest version in august this year.
Is there a possibility that the rams doesnt work well together? But i bought it in a set. I tried placing 4 x 8GB kit, (2 different brands from each other) and they were working fine, showed 32gb.
So since my motherboard is readying 4 x 8GB sticks even though they are different brands, high chance my 4 x 16GB kit is faulty am i right?
 

ASK THE COMMUNITY

TRENDING THREADS