Question 8gb ram installed only 3.95 usable

Feb 1, 2020
3
0
10
0
So here's the thing, yesterday i decided to clean up my pc so i pulled out everything, except cpu which was stuck with bad thermal paste to the cpu cooler. So i used a bit of strength and pulled harder to separate them but unfortunate my cpu fell down to the floor, no pins were bent but one edge of the cpu is little broken, just a little bit. So i packed everything back and luckily it worked except it was showing 8gb ram but 3.95 usable. I tried everything and nothing worked. I cleared cmos, reseted bios, did a fresh copy of windows 10 still nothing. But when i tried changing the slots for my ram my 3rd and 4th dimm slot weren't booting with ram stick in them.. When i use 1st and 2nd ram slot its booting and bios is showing 8gb of ram and slots that are occupied but windows is showing only 3.95 gb usable.. Can anyone tell me what is the problem, is it the cpu that is broken or maybe motherboard problem.. Ram sticks are fine except none of this two sticks works when i try to boot system when they are in 3rd or 4th slot. Currently i put my ram one to another its showing 8gb but it's single channel mode.
my full pc specs are : Gigabyte ab350 gaming 3
Ryzen 3 1200
8gb ram 2133 mhz 2x4 gb sticks
 
Feb 1, 2020
3
0
10
0
You have most likely damaged the CPU.
BTW next time this happens you need to heat up the heatsink either with a heat gun or hair dryer, or even by just running the system for awhile before tearing it down, this will make the tim more pliable.
Oh man, thank you for the answer, i will look up for a new cpu and do an update on this thread if anything changed
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts