Question 98% Memory Usage Task Manager

Sep 14, 2019
12
1
15
0
So I keep getting lag when making things fullscreen and dragging things from 1 monitor to the other. I have 16GB of RAM but task manager says I'm using 98% of my memory. Here is a screenshot of my task manager. I'm sure there are better things to check ram usage but task manager is all I have atm.
 
Sep 14, 2019
12
1
15
0
I will try a reboot but this isn't the first time it has happened. It always comes back. Here is a screenshot with BDO Vivaldi and Steam closed but it still is using almost 14GB of RAM.
 

Joakim Agren

Proper
Sep 5, 2019
142
20
115
7
This is my entire build.
Oh so you have a proper discrete card so was not the issue I was thinking about. In task manager go to the performance tab and at the bottom you should find a resource monitor link. Open that and then select the memory tab and choose to sort after Dedicated memory. This should show what is taking up all that memory...
 

Joakim Agren

Proper
Sep 5, 2019
142
20
115
7
Not sure how to sort by that but I did Commit in one of my other screenshots? Here is another one but idk if I did what you wanted.
Select the Working set tab and there (one click on that tab should show a down arrow and another click a up arrow, when the arrow is down it shows from biggest to smallest) and it should show the processes that currently uses the most memory to be on top of the list. if you select the Commit tab and make it show down arrow. Then that should show the biggest processes as far as allocated memory is concerned. Allocated and working memory is different, both should be checked.
 
Sep 14, 2019
12
1
15
0
Well, it shows this but I did a reboot and I know it isn't my browser. I've also closed the browser and it stayed at around 14GB being used. Vivaldi is my browser if you didn't know that.
 
Sep 14, 2019
12
1
15
0
Did another reboot after a friend told me to uninstall RivaTuner that came with MSI Afterburner and I'm down to 4.5GB being used so that may have fixed it? Then again it normally fixes with a reboot so I can't be sure that was it for a while.
 

Ketchup79

Prominent
Aug 7, 2019
754
71
490
20
So, I see your game, black desert, using almost all your RAM. Did you disable your page file? Other than that, it's a game that loves RAM. Not much you can do about that (ouside of buying more RAM) unless it us one of those games with packs and ad-ons that are consuming the extra RAM.
 
Sep 14, 2019
12
1
15
0
I did a reboot that didn't fix the problem and Black Desert wasn't open after that reboot so that wasn't the problem. I do however have a problem with my pagefile being 14.8GB? Not sure if it should be that large o_O but I just checked it and that's what it was set to.
 

Ketchup79

Prominent
Aug 7, 2019
754
71
490
20
Ok, good. Windows manages that size. If you have a small amount of RAM, that page file can be up to double your RAM, but with more RAM the page file will "shrink" down about equal. You can certainly go in and cut the smallest/largest size down to about 8 GB and see what happens.
 
Sep 14, 2019
12
1
15
0
Weird thing is that it wasn't on auto? Apparently it was just set to about 14GB for some reason. Now the question I have is that if I have an SSD and an HDD do I want the pagefile to be on the SSD or HDD?
 

ASK THE COMMUNITY

TRENDING THREADS