9npa3ultra - NIC no longer working


Sep 6, 2005
Had some problems with overheating after my water cooler pump decided to go on strike indefinitely.
I replaced the water cooler with a simple but extremely large air cooling rig.

Afterwards the mobo Ethernet port quit working. In looking in the hardware details, it looks as if windows is recognizing it as a standard NIC port rather than using the specific Nvidia drivers. I plug in my cord and there is one green light but windows never recognizes the network. I have tried reinstalling the Nvidia drivers and windows does not recognize them automatically. So I tried to manually install the drivers. The installation process repeatedly can not find the proper files, but I again manually point to the driver locations. The system then abruptly restarts without warning.
Windows will not boot until i boot into safe mode w/o networking or restore to previous working settings (which reverts back to the generic networking driver).

Any thoughts?


Jun 6, 2005
I have an EPOX EP-9npaj+ultra (same chipset and NIC) and the nic on it died recently in a weird kinda way. XP sees the NIC but I cannot use the NIC through a switch or with a P2P connection. If I connect it directly to the router then I get internet but thats it. None of my other computers on the network had that problem so I ordered an Intel Pro1000GT gigabit card and that took care of it. It has also been acting funny when I start it. I have to push the power button many times before it will actually start. I am not sure if its the power supply and have a new one on order to check. My whole board could be slowly dying :(