a complicated issue about Port Forwarding

1zyzo1

Commendable
Jul 8, 2016
18
0
1,510
0
hi guys
i have Tp-link router with an updated bios and it works perfectly
my only problem is with Port Forwarding, it just not working.
so here is the long story, i just installed the game "ForHonor" and it require a couple of Port Forwarding ports to i be able to play,here is what i tried:
1-getting a DDNS from no-ip
2- contacted my isp and they told i should buy static ip
3-screwing them and putting a static ip manually
4-activated UPnP and DMZ in router settings
and still nothing
here is a screenshot for my sittings
https://imgur.com/a/MRU13Rq


solved by getting fixed ip from my isp
 

asoroka

Distinguished
Apr 19, 2009
1,201
0
19,660
222
You can't arbitrarily decide to have a static IP.

If your ISP does not give you a static IP, then you have a dynamic IP that can change on the router side.
Dynamic DNS allows you to update DNS whenever your IP changes, however there will be replication lags and there will be times when your "friendly" name will not work.
 

1zyzo1

Commendable
Jul 8, 2016
18
0
1,510
0


i digged a little bit in this issue and yes! i have dynamic ip, because the ip in the router's status is different from the ip i get when i check my ip online
but my question is there a way around it ? can i still port forward with dynamic ip ?
 


Research a little on what a NAT is for and how public ips are sold.
Your ISP gives you the ip on the WAN interface of your router.

On the LAN side you have full control over your IP. You will have to use an ip from the private blocks, but I'd recommend setting is a fixed lease under DHCP to your PC's MAC address. Most consumer routers use the 192.168.x.x private ip blocks.

The ISP can run a firewall and not allow certain destination ports. You might have to pay more if this is the case.
If it's a cellphone internet provider you won't be able to port forward.

Once you have configured your port forwarding to redirect traffic to your private ip for a specific port you also have to make sure that your computer isn't blocking that port with a fw.

Then turn the service on and test it by trying to connect to your public ip address/port.

 

1zyzo1

Commendable
Jul 8, 2016
18
0
1,510
0


-my internal ip is static i'v put it to 192.168.1.150 so it dosn't change overtime and that is that same ip i put in the port forward page on my router
-i'v turned my firewall off a while ago so i don't think this is the case
 


ok, what about the other half of what I suggested?
 

asoroka

Distinguished
Apr 19, 2009
1,201
0
19,660
222
Your problem is always going to be in landing the traffic on the ISP side (at your modem/router). That IP address is dynamic so you need to work out how the other side is going to find you.

Once you do that you can then set your router rule to route all traffic from the ISP side (for a port range) to an internal IP (192.168.xxx.xxx) of your PC.

Your rule will only work if the external traffic can get to your modem.

So as said before, you may need to pay extra.
 
Problem 1: You seem to state you are using NO-IP DDNS, so did u set this up correctly? You are running the NO-IP DDNS client to update yourdomain.com in a regular intervals yes? So this is done.

Problem 2: The above says you are allowing UDP ONLY, then you go testing for TCP? Huh?
 

1zyzo1

Commendable
Jul 8, 2016
18
0
1,510
0

yes no-ip ddns work correctly i have the client
that was just me messing around with the test i know the port is UDP

 

ASK THE COMMUNITY