Discussion A curious case of coil whine

May 6, 2021
7
1
15
This is a story of an interesting case of coil whine, which I recently encountered and found a "fix" for.

So it began with me formatting my computer for the first time in about 5 years for unrelated reasons - read: another weird issue, but nothing to do with this one.
I formatted my primary, installed win10, installed the necessities and so on - nvidia control panel was installed by windows automatically. So far so good.

Then I had a brilliant idea, to update my BIOS, which was from 2016. Download > USB > restart > flash > updated with the newest Asus Maximus Hero X BIOS, from July, 2021.
When I booted to windows I noticed a peculiar squeal when I moved my mouse. Only when I moved my mouse, only in windows. I either didn't notice the squeal before updating BIOS or it wasn't there.

I have a vague recollection of dealing with this in the past, but I can't remember what I did to fix it.

The graphics card drivers should help right? They didn't - installed GeForce experience and the latest drivers, but the coil whine was still there.
At this point, I identified it was coming from the computer, not any speaker and I thought it likely that it's the graphics cards, since one of them is prone to whining at load.
After a reboot, the coil whine was gone, so I though the problem to be resolved and went to sleep.
Next day, the whine was back. As soon as I was moving the mouse, the graphics card(s?) started complaining.

I googled for the problem and found an old article, which states, that enabling windows mouse trails somehow fixes the issue. Tried it, but it didn't work for me.
The next thing was my mouse and USB ports. Tried every other port I have, including the front panel and a different (although still wireless) mouse. Still whine, still consistent.
Tried to disable SLI. Still whine.
Tried unplugging the monitors. Still whine.
Installed kali linux onto a USB drive and booted from it. No whine. Could be because the computer was just restarted.

So I continued with the obvious - unplugged the PC, cleaned out the few kilos of dust that accumulated over the last year, pulled out the graphics cards and used the integrated intel one.
No whine.
Plugged in one of my Asus Strix Nvidia GeForce GTX1080 - no whine.
Pulled the first one out, plugged in the other one - no whine.
Plugged in both cards and the SLI bridge - no whine.

Okay, maybe I fixed it by jittering it around a bit, wouldn't be the first time.
Went on my merry way of continuing to use my computer for the arduous work of displaying cat videos.
And the whine suddenly came back.

Now, at this point, I need to clarify; this was not a quiet noise.
This was like dragging my mouse over a glass table with fine sand on it.
It was loud, high pitched and annoying.
It felt like the computer mocking me every time I moved the mouse.
Like those 90s hacker movies, where every keypress has a boop and a beep, except it was a mouse movement IRL and it made no damn sense!

After some more googling, I came across a suggestion to use a stress test, to... Somehow exercise the coils? I don't know enough about hardware to understand why it would work, but I tried anyway.
I got 3DMark on sale and ran the stress tests. Still whine.
I then fiddled a bit with gSync settings in Nvidia control panel and noticed something interesting - when I clicked save, for a few seconds, no whine, then the whine came back.
Go figure.

At this point, I was angry, frustrated and the constant noise whenever the cursor moved was a testament to my ineptitude.

So I downloaded and installed asus' GPU Tweak II.
I wasn't interested in fixing the problem anymore - I was out for revenge.
I was going to burn these two * [Moderator edit to remove profanity].

Tune them up to high heavens, put a stress test on and wait for the smoke. And if that didn't work, I still have my drill.
That'll give me an excuse to buy a new graphics card that maybe won't put me in a mental institution.
When fiddling around with the settings in GPU Tweak, I noticed a thing called "OC Scanner" - an automatic overclock:
AYEKhAG.png

So I clicked it - as you do when facing an unknown GUI - and I started the scan.
And the whine stopped!

I found that the whine will come back immediately after closing the program and it doesn't go away when opening GPU Tweak again.
It stops when I run OC Scanner, I do not have to apply the OC settings and I can minimize the program and continue using my computer.
In other words, I seem to have stumbled upon a coil whine, that is confined to windows OS, appears only when moving my mouse, and stops when a particular algorithm within a GPU overclocking application is executed.
An reappears when the application is closed.

Now, I'm not a hardware expert and I have no idea what I'm doing - as evident by the above - but I've seen some weird things in my time, including a PC that refused to work until some percussion maintenance was applied in the form of a solid kick.
But this - this takes the cake and then some.
I thought coil whines happened when a card is under load - definitely happened with the two of mine, when playing games like new Assasin's Creed, so I don't... What am I even looking at.
Anyway, I hope this wall of text isn't too boring and if anyone can shed some light on this truly bizarre issue, let me know. Otherwise, I have my so-called "fix" :)

Edit: ignore all of the above, the fix is bogus. When I close the OC Scanner, apparently GPUTweakII.exe will burn about 8% of CPU cycles. Tried closing it and opening aida64 and running a CPU stress test and sure enough, the whine is not audible after the CPU load is high, so BRB, going to bash by head against the BIOS wall a bit more.
Spec edit:
Motherboard: Rog Maximus X Hero
CPU: Intel Core i7-8700
GPU1: Asus ROG-Strix-GTX1080-O8G-11Gbps
GPU2: Asus ROG-Strix-GTX1080 Gaming
MEM: 2x KINGSTON HyperX Fury HX426C16FB3/16
PSU: Corsair HX-750W 750 W
 
Last edited:
May 6, 2021
7
1
15
Update your post to include full system hardware specs and OS information.

PSU: make, model, wattage, age (5 years?).

Are you able to narrow down the source location of the whine?
PSU: Corsair HX-750W 750 W, bought in 2012, so almost 10 years.

I haven't been able to narrow it down yet - should be somewhere near the graphics cards, but I'll check if I can't figure it out. Edit - I think it's somewhere around the CPU, I'll unplug the graphics cards again and let it run for a while to confirm.

I just tried to disable legacy USB, which helped temporarily - it just started to whine again after about 20 minutes of uptime.
 
Last edited:
May 6, 2021
7
1
15
Yeah, it's not the graphics cards, they're both out. Started whining again after about 20 minutes (almost on the dot).
Since this started happening after I upgraded the BIOS, I'll try installing the version I had and see what happens.
Edit: downgrading the BIOS did not work. I think I may need a new computer :(
 
Last edited:
May 6, 2021
7
1
15
I think (read: hope) I got it. Here's what I did since yesterday:
  • Verified that Kali does not have a problem even after waiting for 25 minutes.
  • Tried booting into safe mode windows, waited for 25 minutes and there was no whine.
  • Started to suspect malware due to the 20 minutes detail above, went to format the primary and interestingly, when I was in the windows language select menu, the coil whine upon mouse movement was there.
  • Plugged in a steam controller to test against it's touch pad - no whine.
  • Found an old mouse to test against - no whine. Which is interesting, since I already tested with another mouse, except it was a similar gaming mouse to the one I currently use.

Turns out, if I set my gaming mouse (g502) to lower report rate (250 reports per second), the whine does not appear or is inaudible.
Since the mouse was in on-board memory mode, the report rate didn't change when reinstalling windows, so I never suspected it.
I'm not even sure anymore that the BIOS reinstall had anything to do with it - unless a critical setting that I don't remember from before got reset to default. I did try all of the settings I normally mess with though.
It could be a coincidence that it started to whine now, since it seems that some windows driver, in combination with my mouse hammering the USB is what ultimately triggers it and different version of BIOS do not help.

Anyway, looks like the solution for me will be dropping the mouse report rate to 250 and I'll probably need to replace the motherboard and CPU sometime soon.
Time for me to stop spamming :) Thanks for reading and have a nice day!