A Gigabyte tale of USB woe!


If you've been reading here for any amount of time, you've seen me fix a couple machines just by having people unplug USB devices, and you've probably seen (likely more than once) my lecture about the "Legacy USB storage detect" (AKA "USB storage function" in later BIOS) wanting to be off for most purposes. These two items account for most of the 'dreaded GB reboot loops'... Had an interesting experience in the past couple days that is a perfect illustration:

I have had a number of USB devices in my X48-DS5 for a long time - HID (Logi G11) keyboard, mouse, ESA fan controller board, IR remote eyeball, webcam, and most important to this narative, an 8G HyperX thumbdrive, used for ReadyBoost - no problems. Did have a peculiarity several months back, when I tried to install a USB connected X-10 house control repeater - software refused to install, as it appeared never to 'find' the device - never thought much about it - put it on another system without as much crap loaded onto it, can remote it from anywhere on the house net - didn't care... Couple days ago, was browsing at HackMediaCenter7, where they mentioned better performance for your 'live TV' pause buffer by moving it to a thumbdrive - had a couple laying around (8G OZC 'Diesels' - free from NewEgg with some OCZ DDR2-1150 for testing) so thought I'd try it - wasn't happy, put it back, and rebooted with the 'Diesel' plugged in - WHOOPS! - two reboots, with a brief power-down between them - VOILA! - overclock gone! Loaded saved OC from CMOS storage, saved & rebooted - WHOOPS! - two reboots, with a brief power-down between them - VOILA! - overclock gone again! Hmmm... Pulled USB stick, loaded saved OC from CMOS storage, saved & rebooted - back to normal! Hmmm... Put stick back in - same problem repeated! Thought, just for the sake of testing, let's enable "USB storage function" - saved, rebooted - and rebooted, and rebooted, and rebooted - AH-HA! The dreaded 'GB reboot loop'! Replaced the first Diesel with the second one, just for thoroughness' sake: same performance repeats - "USB storage function" disabled, loses OC every boot; "USB storage function" enabled, reboot loop! Mind you, HyperX and Diesel both 8G, both formatted NTFS, neither containing boot files - one good, one not so good...

So, that's exactly why I recommend unplugging USBs when trying to escape from the 'reboot blues'...


Jul 23, 2009
This really should be stickied somewhere. I had the same problem for a while and tried everything except unplugging my USB peripherals until I came across one of your earlier posts.


My favorite one was about three months ago - someone had had a USB external backup drive plugged into his system for some time, powered down, no problems - when, unbeknownst to him, his daughter flipped the power switch on the external, and ZAP, the reboot loops!
Yup. Gigabyte boards have a tendency to have this problem. I think what's happening is that the BIOS is trying to boot from the USB drive and since it can't find the boot files it reboots and we all know when rebooted multiple times in a short period of time it clears the CMOS. However, if I have a Linux Live USB things work fine :D (as in it boots to Linux with out problem,etc). Hence, my conclusion.

Like you it's happened to me a few times on multiple Gigabyte boards using the P35/P45/X38 chipsets.

Similar threads