graphicsgriffin

Distinguished
Feb 20, 2011
46
0
18,530
Hi everyone,

I have a desktop with no wireless adapter, and a laptop with wireless internet connection through a wireless router.

I connected the laptop and desktop through a direct LAN cable
Enabled ICS on the laptop
Set the desktop's IP address to automatic
Set Bitdefender which is installed on both systems to trust the LAN

Still, I cannot access internet from the desktop. I can access the laptop from the desktop and vice versa through Windows explorer.

Both systems have Windows XP SP2.

Any help please?
 
Solution
You don't need ICS to accomplish this task. ICS is both a bridge and a router (that's why it has its own DHCP server and creates its own network (192.168.0.x)). But you already have a router! So ICS is overkill. You only need a bridge. Go to Network Connections (Start->Run, type "ncpa.cpl" (no quotes), and hit enter), select the two connections, right click, and select Bridge Connections. That's it. Now the desktop can sends its DHCP request over the bridge to the wireless router like every other device.


On the desktop, run the Network Setup Wizard in Control Panel and blob the radio button that "this computer connects though another computer" and don't bother to create a network setup CD. Restart and try the system again.

I can't help feeling things would work better under SP3 and the 130 some subsequent updates.


 

 
You don't need ICS to accomplish this task. ICS is both a bridge and a router (that's why it has its own DHCP server and creates its own network (192.168.0.x)). But you already have a router! So ICS is overkill. You only need a bridge. Go to Network Connections (Start->Run, type "ncpa.cpl" (no quotes), and hit enter), select the two connections, right click, and select Bridge Connections. That's it. Now the desktop can sends its DHCP request over the bridge to the wireless router like every other device.
 
Solution

graphicsgriffin

Distinguished
Feb 20, 2011
46
0
18,530
@ Saga Lout, I already tried that. Thanks anyway

@ tigsounds, I am actually now using an Ethernet switch, after the direct cable failed in the first try. Thanks anyway

@ eibgrad, I have just tried this now, it's just not working. Should I change the IP settings of the bridge or leave it as automatic? Both ways it's not working. The two systems can connect to each other, and the laptop can connect to the wireless internet router, but still the desktop cannot connect to internet. I also tried to set Bitdefender on both systems to trust the network and allow all systems.

What about ip settings, for desktop, laptop, and bridge, static or automatic?