Question A new build PC worked for a day and stopped

Sep 6, 2019
2
0
10
0
Hi guys,

I know there are a few similar threads which I have already read. I also found this guide:

https://forums.tomshardware.com/threads/perform-these-steps-before-posting-about-post-boot-no-video-problems.1285536/

which is very good. However, I still can't figure out why my PC is not working. Please, help!

The problem is that the PC does not boot since yesterday morning. After assembling all parts I turned it on I checked the BIOS options and enabled USB booting to install an OS. I could see the CPU and the RAM showing the correct details in the BIOS. The CPU temperature was 35 degrees Celsius. I managed to install Ubuntu 18.4 the night before and it was working fine for a couple of hours while I attempted to connect it to the internet via cat7 cable. I installed the little MOBO speaker and enabled the boot beep from the BIOS. I turned it OFF/ON a few times and restarted it to test how it works and it worked as expected. I could also hear the beep every time I turn the PC ON. After I turned it OFF I also unplugged the power cord. Unfortunately, when I turned it ON yesterday I did not hear the beep. It also did not show up anything on the screen. In less than a minute it turned OFF and then turned ON again. It keeps doing that ever since and I don't know why would that be. Do you have any idea? I would very much appreciate any help.

I tried many times everything I have found on this forum and in the guide above but still can't figure it out.

Please, find the pictures I have attached to see how the configuration looks like if that helps. Thank you!

Regards,
Dimitar
 
Sep 6, 2019
2
0
10
0
Thank you for your quick reply. I am sorry for not posting my entire system components. My configuration is as follows:

ASROCK Z390 PHANTOM GAMING SLI, INTEL Z390, 1151, ATX, DDR4, XFIRE/SLI, DVI, HDMI, 2.5GB LAN, RGB LIGHTING
1
INTEL CORE I9-9900K PROCESSOR 3.6 GHZ BOX 16 MB SMART CACHE
1
CORSAIR H115I PRO LIQUID COOLING PROCESSOR
1
CORSAIR TX850M 850W ATX BLACK POWER SUPPLY UNIT
1
GAMEMAX VOLCANO GAMING PC CASE RED LED FRONT FANS
1
SEAGATE BARRACUDA 510 INTERNAL SOLID STATE DRIVE M.2 512 GB PCI EXPRESS 3.0 3D TLC NVME
1
HYPERX PREDATOR HX430C15PB3K2/16 MEMORY MODULE 16 GB DDR4 3000 MHZ

Thanks again for looking into my issue.
 

ASK THE COMMUNITY

TRENDING THREADS