A Problem with Nvidia geforce experience

ilikehardware

Commendable
Aug 19, 2016
10
0
1,510
0
So I didn't use geforce experience for a while and when I launch the app it WON'T run the app but will ask me to run a file called Geforce_Experience_Patch_v1.0 in UAC mode (user account control message) .
Is it legit and safe to run this ?
And what should I do ?

Here is a picture of what I'm talking about
http://imgur.com/a/c9XHG

Thanks for any help :)
 

t53186

Distinguished
Aug 6, 2006
1,722
0
20,460
321
It's practically impossible to install Experience and do something wrong.

That path look legitimate, but like I said, never saw nvidia release a patch, and there is a first time for everything. I'm just very cautious and won't give you advice (like, go ahead try it) if I wouldn't try it myself.
 

t53186

Distinguished
Aug 6, 2006
1,722
0
20,460
321
I wouldn't, only because I've never seen nvidia release a patch. Usually that's done with a new driver that is WHQL signed. I'd download the latest version of experience and load that instead
 

ilikehardware

Commendable
Aug 19, 2016
10
0
1,510
0


So how can I reinstall Geforce experience properly without doing something wrong ?
And also that is the file's path
http://imgur.com/a/3kSyR
 

t53186

Distinguished
Aug 6, 2006
1,722
0
20,460
321
It's practically impossible to install Experience and do something wrong.

That path look legitimate, but like I said, never saw nvidia release a patch, and there is a first time for everything. I'm just very cautious and won't give you advice (like, go ahead try it) if I wouldn't try it myself.
 

ASK THE COMMUNITY

TRENDING THREADS