Question A very specific type of Flickering!

Oct 9, 2020
1
0
10
0
Hi there, this is my first post here. Just found about this forum when almost giving up on an issue with my newly acquired GPU. The thread that brought me here was this one, with a guy posting a similar issue. Since he managed to get help to solve the issue I figured it was worth giving it a shot aswell :)

So I've been experiencing some issues with my Radeon RX 580 since installing it last week.
I've always used a two screen setup (it work flawlessly with my old computer) where my main monitor is a Dell U2410 (via displayport) and my second screen is my TV (Samsung 50RU7100 via HDMI).

But since starting with this new pc, when the second screen is turned off, my first one starts blinking and flickering nonstop. It happens sort of randomly (even if the pc is idle on the desktop with no particular software/game running). But it always happens in about 30 to 60 minutos after shutting off the TV.
Important notice: the issue only happens on the first screen when the second screen is turned off.

Here's how it goes:

The only way to make it back to normal again is by:
1 - turning the tv on again
2 - removing the HDMI cable from the gpu


Kind of already ruled out cables as an issue (tried 3 different HDMI cables on the tv, everyone of them already testing and working properly with other devices). Also tried plugging my monitor to the GPU with another HDMI cable instead of the display port one.

Already reinstalled the GPU drivers 3 times, always cleaning up before doing so with DDU. The last time I even did a fresh windows install to see if I could manage to get it right, but... nope. Problem still occurs.

My bios are already up to date aswell.

I don't know what else to try so figured it would be better to ask here.

My specs:
Asus Prime B450M Gaming/BR, Chipset B450
AMD Ryzen 5 3600 3.6GHz (4.2GHz Turbo)
2x DDR4 Kingston HyperX Fury, 8GB 3200MHz
Sapphire, Radeon, RX 580 Pulse Dual
SSD WD Blue 1TB, Sata III
Seventeam 650w
 

ASK THE COMMUNITY