A8N SLI Premium not respondng to power switch


Feb 22, 2009
This morning I pressed the button to turn on my computer, and... nothing! The bottom line is, my motherboard doesn't respond to the power switch. Otherwise the motherboard is fine. I'm typing this on my computer right now with a jerry-rigged switch hooked into my ATX connector forcing the power supply on.

Any ideas on how I can fix this?

So, here is how I arrived at where I am.

-Checked inside case. No obvious burn marks on motherboard. Green LED on motherboard is lit.
-Checked power button connection, connection is good.
-Checked power button with ohm-meter, switch functions properly. (zero ohms when button depressed)
-Tried the short the power switch pins on the motherboard with a screwdriver trick. Nothing.
-Removed CMOS battery, cleared memory, tried power switch, nothing.
-Removed power supply completely. Opened it up, no obvious burn marks.
-Blew out power supply and computer. (it got a bit dusty)
-With power supply still removed, forced power supply on by shorting the green wire to ground.
-Checked all outputs with voltmeter, all voltages present.
-Re-installed power supply, connected just the ATX and 4-pin connector, removed all expansion cards, RAM, did not hook up -hard drives. Still nothing with the power switch.
-Finally, forced power on by shorting green wire to ground. Got error beeps.
-Installed memory and video card, again forced power on by shorting the green wire. Got into BIOS.
-BIOS hardware monitor shows all voltages present.
-Tried enabling BIOS options to power on the computer using keyboard and mouse. Did not work.
-Hooked everything back up, short green wire to ground, system boots to Windows fine.

So, now I have a switch with a 100 ohm resistor wires in series. This is hooked into the power supply ATX connector, and I'm using it to force the power supply on.

The only thing I can think of is the circuit which handles the power switch has opened up. I did try checking from the ATX connector on the motherboard to the power switch header, and did not get any sort of reading. But I'm not sure what this could normally be.

Or is there a circuit inside the power supply that may have gone bad? But if that is the case, why won't it turn on if I simply hold the power switch down? (yet it turns it on if I short the green wire to ground)

Anything else I can try? Also, are there potential hazards to running my system with the power supply forced on as it is now?



Dec 31, 2007
So what happened here? I'm having the same problem. Computer was working fine. Shut it down to blow out the dust. Won't power back up. I tried jumping the power switch connector on the mb but that didn't work. Through my searching I found some post that mentioned that maybe a fan connector being loose could cause the power supply to not turn on.

So, to short the green wire to ground I do this before plugging in the ps and then when I plug in the ps it should fire up?

Thanks for the help. I'm not really interested in buying a new mb/cpu/ram right now.

I should also mention that the fan on the south bridge started making noise. I jostled it some and the fan/heat sink came loose. I'm assuming that's ok as it is spring loaded to keep it on the chip. Perhaps the fan connection came loose and it my problem.

Similar threads