Question About my gaming wheel/pedals.

Aug 1, 2019
4
0
10
0
So I have a thrustmaster red legend edition and i used it in euro truck simulator and everything worked fine, wheel and pedals.
However, i started playing f1, and I repared in a problem that I can't find the solution anywhere. When I press the throttle/brake pedal, even if its not in is maximum reach, the throttle just goes right to 100, it doesn't go like 0-1-2......-99-100 it's not smooth. That just makes the game harder because in a turn that i just need to desaccelarate a little bit, or I just don't press the throttle pedal and lose a lot of time or i brake with all the force losing more time. In the thrustmaster control panel, it seems the pedal already starts at 50%, like something was pressing them instead of 0%, when i press it goes right to 100%.
Is there any solution? I would aprecciate.
Thank you.
PS: If you like to see some pictures say in the comments.
 

Ralston18

Titan
Moderator
Have you tried reinstalling the drivers?

Are there any calibration screens?

Are you able to try the wheel and pedals on another computer to determine if the problem follows the wheel and pedals?

Or try other "driving" controls in the game to determine if the game is working as it should,
 
Aug 1, 2019
4
0
10
0
Yea I tried reinstalling and nothing changed.
About the calibration screen, this wheel control panel just shows the test input and i can't calibrate nothing, i thought about that to, but can't find a solution too.
Already tried last two things so I don't know what to do.
I just want a fast answer because I bought f1 2020 and i wanted to drive with wheel and pedals but it seems it's gonna be impossible.
 

ASK THE COMMUNITY