• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question About to give up, lag spikes in game with low ping and no packet loss.

Nov 16, 2019
4
0
10
0
About a few days ago I started an issue with playing games with low ping, but getting lag spikes that seemed like an internet issue, but ping stayed the same, and my internet was fine. I recently downloaded the new windows update (1903) and I want to say thats the issue, but I have uninstalled it and it still continues to spike. About a day after trying to fix it, not only did I get lag spikes, I started getting FPS drops aswell. Ive done everything but buy a new computer at this point. Ive talked to XFINITY support 2 times, they said my internet was perfect. Ive reinstalled all my GPU drivers, renewed IP, reset internet 5+ times. I have a competition monday for CSGO, and I need it to be fixed pretty fast. I need help DESPERATELY. Edit: Forgot specs. GEFORCE GTX 1080, I-7 8700K, 16 GB of RAM.
 
Nov 16, 2019
4
0
10
0
Tell me what you are calling "lag spikes." What exactly is happening?

Is your computer running wifi or directly connected to the router?
I’m calling them lag spikes because they are similar to internet spikes, where if you are moving in a game, it will move you back where you came from a few seconds before. My computer is connected directly to the router through Ethernet. I have tried two Ethernet cords aswell.
 

Ketchup79

Notable
Aug 7, 2019
1,406
126
1,090
70
  1. Have you tried with a connection directly to your modem?
  2. If you run an Internet speed test right now, what does it show?
  3. When was the last time to did a power reset on your router and modem?
 
Nov 16, 2019
4
0
10
0
  1. Have you tried with a connection directly to your modem?
  2. If you run an Internet speed test right now, what does it show?
  3. When was the last time to did a power reset on your router and modem?
  1. That is what I currently have, my main PC is connected through ethernet straight to modem.
  2. 220Mbps, doesnt go up or down while "lag" is happening.
  3. This morning.
 
Nov 16, 2019
4
0
10
0
I had a similar issue yesterday, but I figured it out that im having packet loss based on server pings and such. Need help!
 

ASK THE COMMUNITY

TRENDING THREADS