Question AC Odyssey laggs

svat

Prominent
Aug 18, 2020
121
1
585
0
Hello guys, i have a ryzen 5 3600, Rtx 2070, 16gb ram 3000mhz, game installed on nvme ssd. My problem is, when im entering the cities, or looking at them from distance im getting huge stuttering, i saw the fps drop(wich is normal) but there is a Lot of stuttering. I have around 90-105fps when im not in cities(custom settings, volumetric clouds off), when im in cities im getting solid 80. Is there any way to fix it or its just bad optimized. There are things i tried: disabling fullscreen optimalisation, turned off fast startup, high priority in task manager. None of this helps. Btw my temps are CPU max 65(mostly 60) gpu max 73(ventus ;)). Updated gpu drivers. I dont have this problem in any other game, even origins was smooth, there was lag when entering cities but when i was already in them it was smooth, in odyssey there is stuttering everytime when i move with my mouse to some bigger place.

thanks for any help
 

itrip

Commendable
Feb 4, 2019
236
18
1,615
12
Don't worry about it, keep on playing and get your self to next objective (some of the islands aren't as smooth as others)
 

svat

Prominent
Aug 18, 2020
121
1
585
0
Don't worry about it, keep on playing and get your self to next objective (some of the islands aren't as smooth as others)
Im actually at the start in Megharis or how its called, and in Megar capital city i had a Lot of stuttering, cant wait for Athenas
 

itrip

Commendable
Feb 4, 2019
236
18
1,615
12
There one island that really sucks but you wont be there for long its skyros or something, don't worry if you get bad fps there, its just the way the game is, but you might want to investigate further if you get stuttering in more place than are know to cause that.

I wouldn't keep poking at the setting, find something that is smooth in most places and stick with it.
 

svat

Prominent
Aug 18, 2020
121
1
585
0
I dont know, ive had stutters in kephalonia, now on megaris i dont Belive it at all. The game is just bad optimized imo. I remember when i have the game cracked long time ago just to try it and that time i fixed it by disabling fullscreen optimalizations wich isnt working for now. Anyways thanks for your time.
 

itrip

Commendable
Feb 4, 2019
236
18
1,615
12
Ok, glad to help, another thing I did when I played AC Odyssey was to have only that game installed, disabled auto gpu driver updates for the remainder of the game so that nothing on my pc setup changed whilst playing, I'm on my third playthrough now but back then when I 1st played it it took me three month to make it to the end, all the time my pc was nice and stable, and because my pc was nice and stable I did not worry about the poor performance in some islands.
 

svat

Prominent
Aug 18, 2020
121
1
585
0
How can i disable auto gpu driver updates? I dont have installed gpu expirience or somehing, im updating drivers manually trought nvidia site
 

itrip

Commendable
Feb 4, 2019
236
18
1,615
12
Just check the control panel of the gpu and find and disable auto updates that will insure that you can play the game without having to deal with interruptions, its what I believe is needed to have a smooth game from start to finish, it is a long game after all and you will want a stable pc for it all.

I have AMD so I don't know if you can disable auto updates with Nvdia, but it should be possible to keep your pc stable for an entire AC Odyssey playthrough.
 

ASK THE COMMUNITY

TRENDING THREADS