Question Access Denied When Updating USB Driver


Oct 13, 2017
I have just factory reset my computer. I put some files on a USB to bring over after the reset. When I plug in the USB I hear the sound that usually plays but I do not see the drive in file explorer. I opened up device manager to see it is there. However, it has the triangular yellow symbol. That normally means it needs new drivers so I tried searching for drivers. It said it did find new drivers however it couldn't install them because access is denied. After this, it becomes an unknown device under the other tab. I have reset it by using the uninstall device option many times and I have tried everything I can find on Google. I have also tried using the USB on a different computer that I have never used it on before and it works fine by default. Why is it not working by default on my pc and how can I get it working? Thanks.


I've never run into this, so I'm afraid you'll need to hope someone else can be of assistance. I don't do resets because I always make full system backups to an external hard drive. I'll just add that I've read that the Windows reset can be buggy sometimes.