Question Acer Aspire 7 Dead Pixels and screen problems

Dave2299

Prominent
Nov 3, 2019
15
1
515
0
Hi i had just recently changed my thermal paste and since the laptop has been acting weird as it starter getting stuck at welcome screen and stuff now suddenly the laptop is showing dancing pixels like in the pictures i have posted below. it doesn't occur while booting but as soon as it reaches the moment to show a welcome screen it shows a black screen and some green dots and all of a sudden it show the screen with filled pixels. Im in doubt as it is a hardware problem or a software. the laptop turn on but stucks when tired to open start menu, so i can get access to safe mode and i tried using a hdmi to check a external monitor but the results are same which makes me more nervous and scared as i doubt its a huge hardware problem

I have a battery that requires a replacement , but i fixed the startup freeze by disabling fast startup and as i was changing the thermal paste the servicing guy had not unscrewed a screw and tried while pulling the lower cover and the screw was the one attached with the mother board i heard a squeak does it mean the motherboard has taken some damage ? but it worked just fine after servicing all the temps were balanced.

 
Last edited:

hang-the-9

Titan
Moderator
Not sure how you added in the pictures, but they are not showing up. You need to upload them to a file sharing site, then use the Insert Image option to link them.

Image issues with dots on the screen are usually caused by a too much heat to the vide card, a failing video card and can be caused by driver issues. First step, try a clean Windows setup with new drivers from the laptop vendor site. Don't use any 3rd party driver updater. If that does not fix things, you may have not done the thermal paste properly, used too much, or too little or the heatsink is not on the CPU properly.
 

Dave2299

Prominent
Nov 3, 2019
15
1
515
0
hi yes i use to game a lot and the temp used to reach 90 and shutdown some time, then i reapplied the paste , but i cannot update the driver as im unable to use my laptop and i went some places they were shocked and had not seen this before and one guy said that tit might be caused due to inter graphic or intel cpu damage im not confident to show at a repair shop before i get help from here cause they always try to snatch more money from small errors that can be fixed easily.
 

Dave2299

Prominent
Nov 3, 2019
15
1
515
0
Not sure how you added in the pictures, but they are not showing up. You need to upload them to a file sharing site, then use the Insert Image option to link them.

Image issues with dots on the screen are usually caused by a too much heat to the vide card, a failing video card and can be caused by driver issues. First step, try a clean Windows setup with new drivers from the laptop vendor site. Don't use any 3rd party driver updater. If that does not fix things, you may have not done the thermal paste properly, used too much, or too little or the heatsink is not on the CPU properly.
hi i just uploaded the pictures hope it is available to view now
 

Dave2299

Prominent
Nov 3, 2019
15
1
515
0
Try a clean Windows setup, that screen does not look like a temp issue.
Hi just fixed the laptop it is found out that the intel hd graphics was damages and he has disabled it so now it is running on NVidia graphics card but it cant run games and the video quality is sooo <Mod Edit> man, any fix to it ?
 
Last edited by a moderator:

hang-the-9

Titan
Moderator
Hi just fixed the laptop it is found out that the intel hd graphics was damages and he has disabled it so now it is running on NVidia graphics card but it cant run games and the video quality is sooo <Mod Edit> man, any fix to it ?
Games should be fine on the nVidia card, in fact they should have been running on that even if the Intel one worked. There may be an issue with the video card switching, go to the settings of the video card drivers and make sure it's set to nVidia as the main and also for game use. You probably want to check for newer drivers from the laptop vendor.
 

Dave2299

Prominent
Nov 3, 2019
15
1
515
0
Games should be fine on the nVidia card, in fact they should have been running on that even if the Intel one worked. There may be an issue with the video card switching, go to the settings of the video card drivers and make sure it's set to nVidia as the main and also for game use. You probably want to check for newer drivers from the laptop vendor.
Hi i have completely disabled intel uhd grpahics cause if it enabled my laptop will be as the same in the mentioned pictures, the nvidia controll panell is unaceesable in my laptop and the video quality has been very bad bluddrylines and more, the laptop games i used to smothly run are lagging very bad and unplayable , im afraid it also can be because i have a older version of nvidia drivers and im scared to udate it through ge force exprience cause i think it might be damaged again.


As per the thread entioned above my VGA has been set to basic mode so is there any chance i can fix this grpahic and game lagging problems ?
 

hang-the-9

Titan
Moderator
Hi i have completely disabled intel uhd grpahics cause if it enabled my laptop will be as the same in the mentioned pictures, the nvidia controll panell is unaceesable in my laptop and the video quality has been very bad bluddrylines and more, the laptop games i used to smothly run are lagging very bad and unplayable , im afraid it also can be because i have a older version of nvidia drivers and im scared to udate it through ge force exprience cause i think it might be damaged again.


As per the thread entioned above my VGA has been set to basic mode so is there any chance i can fix this grpahic and game lagging problems ?
If you have a hardware issue where the video card is faulty, nothing you can do aside from replace the motherboard. Did you do a clean Windows setup with the drivers from the laptop vendor? You said something earlier about having to run in safe mode, in safe mode you will not get any real video card speed since the drivers are not loaded.
 

Dave2299

Prominent
Nov 3, 2019
15
1
515
0
hi yeah the vendor says the mother board need to be changed and it seems it takes around 4 to 600$ in cost nothing can be done it seems and yes i did the complete setup cleaning no change
 

dorsai

Distinguished
If the problem started when you replaced the thermal paste my guess is it was not properly cleaned and/or the new paste was not applied correctly. Pixelated graphics like your screen shots is often the result of thermal paste getting on the resistors and other components that surround the chip the paste was applied to.

I'd recommend another tear down of the laptop and a careful cleaning with Q-tips all around the chip to make sure paste didn't get onto the circuitry...as well as a full cleaning of the chip and heatsink and a re-application of a thin layer of thermal paste.
 

ASK THE COMMUNITY

TRENDING THREADS