Acer Aspire E5-574-54A8 Ram only shows 4GB on Windows when 8GB is installed

Oct 18, 2018
2
0
10
0
Hi there,

After seeing how helpful people are in this thread I've decided to post for the first time. I'm absolutely new to computer hardware , so please bear if with me if i'm not making myself clear or using the right terms.

I've recently decided to upgrade my Acer Aspire E5-574-54A8 (running on Windows 10 64bit) from 4gb to 8gb ram. I decided to go with Crucial 4GB PC3L-12800 DDR3L-1600M ram, as I saw it being compatible on Cruicial's website.

The problem started right after I installed the RAM, window only shows 4gb, while in CPU Z it shows 8gb. I saw that in the CPU Z Memory tab, the channel # is single, while in the SPD tab, the Cruicial ram ranks "Dual", and running in 1.5V. (screen shots below)

CPU Z and Windows





Ram



I've tried taking out the existing 4gb ram and only install the crucial ram, and window will not boot.
I've also tried system config => boot =? uncheck maximium memory
I've gone into UEFI but there's no options for ram expansion

Did I get myself the right ram? I'm starting to afraid what I've received isn't the DDR3L I thought it would be.

Thanks in advance.
 

cpucpu123

Prominent
Jan 11, 2018
163
0
760
29
The Crucial RAM is DDR3 running at 1.5V, not DDR3L running at 1.35V. Your laptop uses i5-6200U. Intel 6th Gen Mobile Processors only supports DDR3L and not DDR3
 
Oct 18, 2018
2
0
10
0



I've managed to get an exchange from Neweggs and now it's working properly. Thanks for replying!
 

Similar threads


ASK THE COMMUNITY