Question Acer Aspire V5: New batteries refuse to charge

kjammer

Prominent
Jan 14, 2018
7
0
510
0
I bought a new battery from the Acer store for my Acer Aspire V5-571P-6698 because the old battery has trouble keeping its charge. The new one arrived but it was stuck on "0% not charging" I tried uninstalling battery drivers, removing and reinserting it, and leaving it plugged in for 2 hours. Still no improvement. I called Acer and they sent a replacement for free, but even the replacement does the same thing. The report generated by PowerShell only acknowledged the first battery and the others only show up as '-' under the "capacity remaining" column. I doubt Acer would send third battery or offer a refund after I accepted the replacement. Is there a step that I am missing or are both of the new batteries defective? What do I do now?

For context: The old battery was made in 2012 and still works (but not as well as I would like). The two new batteries were manufactured in 2017 and 2016 respectively and they don't work at all.

Other Info:
Have Windows 10 (upgraded from Windows 8)
The Laptop didn't come with a service manual (I don't think any of them do, because they don't want the public to service their laptops).
This model does not have a battery reset pinhole.
I have not yet opened the laptop to see inside.
It goes without saying the 6 year-old laptop is way out of warranty.
 

ASK THE COMMUNITY

TRENDING THREADS