Acer Aspire X1430g


Jun 4, 2012
Our HP died, so we found a Acer Aspire X1430g on clearance at Walmart for $240 so we snatched it up. It was purchased on Friday 6.1.12 and I still do not have it up and running.

When I got it set up I tried activating the Anti virus software that came with it. It just kept saying activating and sat there forever. I tried to visit some websites and some wouldn't load, others would take forever, windows live messenger would not sign in. I did the Acer E recovery since I didn't have a reboot disk made yet. It got all the way to step 29 of 29 and sat there and sat there, not going any further so I shut the computer down. Tried it again, and the same thing happened, it got to step 29 and that's as far as it got. I left the computer alone for 6+ hours while it was on step 29. I'm no expert but I am sure it does not take that long to restore a computer. Frustrated, I chatted with Acer and provided them with the serial number off the side of the unit. He told me that I would have to purchase the recovery disk off their website since the unit was purchased in November 2011. I told him again that it was a brand new unit and he said I would have to fax proof of purchase and serial numbers to prove we just bought it. I asked if there was any way we could check to see if it was installed properly at the factory and he said no, the E recovery was the only way to fix this problem. So, I am really frustrated at why this brand new computer will not work. Is there any other way to get the computer to restore? Should I try it in safe mode? Should I just take the unit back to Walmart, if they will even take it back? Thanks for any help!