[SOLVED] Acer Nitro 5 AN515-53 - How to optimally install m.2 NVME SSD?

ShangWang

Proper
Mar 26, 2021
460
2
185
0
Hi all,

If I were to use a single NVME SSD would I use AHCI or RST? Is RST just used for when you are using two hard drives or should I have RST on for NVME anyway?

Does anyone know the optimal settings to install a m.2 NVME SSD and if I need to disable SATA to use PCIe?
 
Last edited:
Hi all,

If I were to use a single NVME SSD would I use AHCI or RST? Is RST just used for when you are using two hard drives or should I have RST on for NVME anyway?

Does anyone know the optimal settings to install a m.2 NVME SSD and if I need to disable SATA to use PCIe?
Just what I found on this machine.
Testing both ahci and rst on my nvme disk showed no diff in perf.
I set it to ahci and have not seen an issue.

No you do not need to disable sata to use pcie....I assume your talking about the bios.
If your not using sata I doubt it will make a diff one way or the other.
 
Hi all,

If I were to use a single NVME SSD would I use AHCI or RST? Is RST just used for when you are using two hard drives or should I have RST on for NVME anyway?

Does anyone know the optimal settings to install a m.2 NVME SSD and if I need to disable SATA to use PCIe?
Just what I found on this machine.
Testing both ahci and rst on my nvme disk showed no diff in perf.
I set it to ahci and have not seen an issue.

No you do not need to disable sata to use pcie....I assume your talking about the bios.
If your not using sata I doubt it will make a diff one way or the other.
 

ShangWang

Proper
Mar 26, 2021
460
2
185
0
Just what I found on this machine.
Testing both ahci and rst on my nvme disk showed no diff in perf.
I set it to ahci and have not seen an issue.

No you do not need to disable sata to use pcie....I assume your talking about the bios.
If your not using sata I doubt it will make a diff one way or the other.
I see, so the system will automatically detect PCIe if I put the SSD in the right slight and also use NVMe? I don't have to change anything in UEFI?
 

ShangWang

Proper
Mar 26, 2021
460
2
185
0
Every bios is different.
I could send a screenshot of what I have and it would look like nothing not even close to what you see.
Best I can tell you is to look through your bios for an enable/disable screen for different devices.
Will do thanks, could you send me what it looks like for you anyway? Do you know if it's enabled by default usually?
 
Will do thanks, could you send me what it looks like for you anyway? Do you know if it's enabled by default usually?
In my bios is shows in system configuration/drives.

Look at this link.

Scan down to.
Make Sure the M.2 SSD Is Recognized by Your Computer
That pic looks like nothing that I see but again different bios.
 

ShangWang

Proper
Mar 26, 2021
460
2
185
0
In my bios is shows in system configuration/drives.

Look at this link.

Scan down to.
Make Sure the M.2 SSD Is Recognized by Your Computer
That pic looks like nothing that I see but again different bios.
Thanks, do you also believe NVMe needs a heat sink? My motherboard likely doesn't have one, if I wanted to use it for maybe 5+ years is it really necessary to have one?
 

ASK THE COMMUNITY