Question Acer Predator XB271HU tens of bright/stuck pixels?

May 14, 2019
4
1
15
0
It's a bit of a peculiar problem. 2 weeks after I bought the monitor I noticed a very small bright dot in the middle of the screen, that is visible only on a dark background. I seems to be emitting green light but I can't really tell beacause it's very small.

I get very close to the screen and noticed TENS of little lights of different sizes all over the screen.

All of them, except the first one that I described, are visible only when getting close to the screen.

When I change colors they disappear, I cannot see them at any distance and to then naked eye it seems that all pixels are working normally, I don't see any dots that are stuck to a certain color after I change the background color.

Yet these little dots of light are still visible on a black backgorund. I took photos of them from up close and they seem to emit different colors.

Things I tried:
- massaged them and a few disappeared, some reappeared, but the middle ("biggest") one and one at the top of the screen didn't disappear. These are the ones that I can acually find if I try to look for them on black.
-ran JScreenFix appliication for 20 minutes and nothing happened
-unplugged the monitor and plugged it back in
- unplugged the displaycable and plugged back in

I've read about bright pixels, dead pixels and stuck pixels and my problem doesn't seem to match any. It closely resembles bright/hot subpixels or stuck subpixels but that doesn't explain why I can't see them on colored backgrounds anymore, does it?

Being that this is an expensive monitor, what should I do?

I can RMA the monitor until next monday, but is it worth it since I can barely see them? This issue is bugging me pretty hard considering the fact that I may get a new monitor with no pixel problems but with huge backlight bleed or something.

View: https://imgur.com/a/b2JKrSa


View: https://imgur.com/a/cLjhhsM


View: https://imgur.com/a/kuGvDc6


View: https://imgur.com/a/MhMC0OF


View: https://imgur.com/a/xps9sIH
 
Aug 4, 2019
2
1
15
0
I have same problem with my XB271HU pixels one blue and one red they only show in dark background i massaged them and they dissapear for one month then again appear. Still dont know what to do.
 

ASK THE COMMUNITY

TRENDING THREADS