ACPI+WIN2K+A7V+X-GAMER

G

Guest

Guest
Ok, I know this has been covered here. I searched the forums and found that I'm not the only one with problems. Here's my setup.

ASUS A7V MOBO (Latest BIOS Installed)
AMD 1000Mhz
256MB CAS2 PC133
GeForce 2 MX 32MB
SB Live X-Gamer 5.1
Adaptec 2920 SCSI Card
Kingston 10/100 PCI Network Card

I'm running Windows 2000 SP1. ACPI is enabled. Whenever the soundcard is in the system, it will run for anywhere between 1 minute and an hour before locking up. I have to manually reset the computer. I have taken the soundcard out and haven't gotten it to lock up once. I took the soundcard back and got another one. Still the same problem. I have the soundcard in the slot that shares with USB. Last night, I swapped it with the Kingsotn which shares with the "AMR" slots which are disabled. Everything seemed to be working okay but I left my PC on overnight, like I always do. I was downloading the Mandrake ISO and this morning when I woke up my PC was froze. My cable had also lost service and was still not back on. I seriously doubt that could have caused it. I'm not sure if I should try disabling ACPI or what. I simply can not figure out this problem. Oh, here's a tidbit I forgot. Whenever I was building my system I installed everything except for the soundcard drivers, even though it was physically in the machine, and never got it to lock up. Is this a case of bad Creative drivers?

Thanks in advance,
Brad
 
G

Guest

Guest
Hey Brad did you install 2000 with Plug N Play turned on in the bios or turned off? should be turned off.

It may not be your sb. the most common problem with A7V lock-up wise is some obscur AGP drive strength issue that many (but not all) of us have. suggest you run your system at "Normal" rather than "Optimal" for awhile and see if lock-ups stop. if it works on "Normal" you nailed it. the "Optimal" problems did not stop for me until bios v1006 and now I'm kicking but.

ACPI should not matter, I've done a clean install "standard pc" (which eliminates ACPI) and while this makes the irq's look very pretty it works no better than ACPI installed with a dogpile on irq9 (no more DOS irq stuff thank god...); although a sound technical arguement can be made for "standard pc" installation on A7V. Later,

<font color=blue>Jim - Retired A7V Beta Tester (or thats how it feels)</font color=blue> :cool:
 
G

Guest

Guest
>>"ACPI should not matter, I've done a clean install "standard pc" (which eliminates ACPI) and while this makes the irq's look very pretty it works no better than ACPI installed with a dogpile on irq9 (no more DOS irq stuff thank god...); although a sound technical arguement can be made for "standard pc" installation on A7V."

Not true. I have a A7V, AMD-800 thunderbird, geforce 2 GTS and SBLive value. I had the exact same problem.Especially if I would open internet explore or try to play quake 3, the system would freeze completely and I would have to reboot. For a couple of months I was playing with AGP disabled completely because of lockups. After trying every driver known to man, and STILL having this problem, i decided to take the plunge and disable ACPI. Heaven! ACPI IS THE DEVIL!

Seriously tho, ACPI does cause most all the lockups. Just make sure you have the newest drivers from Microsoft-AMD (fixes AGP maximumpagesize, VIA drivers, Geforce drivers (go to 6.31+) as well as promise and so on...

My system is 100% stable with Windows 2000

and disable ACPI, you will thank yourself for it.

- Nekros
 
G

Guest

Guest
Well I thought I had the problem whipped last night. I installed a new bios on my GeForce, I installed the 1006 BIOS on the motherboard. I installed the 4in1 drivers v4.28 I believe and Nvidia driver v6.50. Not a single lockup ALL night long. Burned 2 CD's, was using VMWare to run my Linux box, listened to MP3's, browsed the Net. I was thinking, WOW! Then this morning I got up to get back on and crank up some MP3's while check my email and I was able to listen to 1 or 2. When it started the third one it locked up and the sound was stuck with the annoying BEEP in my speakers. I'm going to try some more things and get back to you guys. I really don't want to disable ACPI, Asus and MS really need to get their crap together on this one because they really screwed the pooch.
 
G

Guest

Guest
well whatever works, works; I have one machine set up on standard pc and one without (which has a major irq dogpile) and not a dimes bit of differance. all I know is that there is obviously no single road up the mountain here: many people have a stable A7V running 2000 right out of the box. the point I'm making is that the core stability issue on A7V is AGP drive strength.

<font color=blue>Jim - Retired A7V Beta Tester (or thats how it feels)</font color=blue> :cool:
 
G

Guest

Guest
well at least we're getting closer :)

I'm running the Via 4in1 4.25 BTW (AGP driver only); I'd heard a few tales about 4.28 but who knows. the 1006 bios at least allows you to run system in "normal" while setting AGP to 4x; this may work.

Also, I'm not discounting removing ACPI as a possible solution (yuck I know) because Microsoft is fundamentally a group of maximum greed marketing dickheads who find fully supporting non-intel chipsets hateful rather than say being a useful technology company/provider; So we wait for SP2. That said I'm not sure of the value of a DOS irq trick but hey whatever works; all I know is the NT5 virtual irq's are working fine here.

Anyway the point I'm making is that the core problem is AGP related and I know I had to try lots of things to get things working perfectly so lets keep trying until we get your machine kickin but because the A7V is AMAZING when you get it there. Later,

<font color=blue>Jim - Retired A7V Beta Tester (or thats how it feels)</font color=blue> :cool:
 
G

Guest

Guest
I forgot to mention that when I had all this luck with my machine last night until this morning I was running Manual AGP Drive Strength using A,7. I also had fast writes enabled. I'm going to try disbaling that optimizing thing tonight and see if that helps. I don't think the IRQ9 stack is the problem kind of like you, but I agree that a nice argument can be made for it.
 
G

Guest

Guest
AGP Fast Writes enabled on my system (very similar to yours: A7V, Geforce2MX) cause win2k to lock hard EVERY time in some apps. (All 3d apps, media player to name a few.) ACPI is almost certainly NOT your problem. It would be very easy to blame it, as all those devices stacked on one IRQ look so very unhealthy (especially to eyes accustomed to ISA), but in reality, if your devices are "clean" PCI devices (meaning they actually follow the spec) there should not be a problem with IRQ sharing. Two things took ALL freezes from my system:

1) BIOS 1006
2) Disabling Fast Writes.

See my system setup at:

http://www.pobox.com/~mjwise/mycomputer.html
 
G

Guest

Guest
Ya I agree with Sparhawk: try differant AGP related settings such as fastwrites on/off, normal/optimal (the built in ones should be fine with bios v1006 rather than manual drive strength settings) etc.

Also it is a good idea to reset bios to default settings prior to flash.

Hows it working now?

<font color=blue>Jim - Retired A7V Beta Tester (or thats how it feels)</font color=blue> :cool:
 
G

Guest

Guest
I have a A7V, TBird 950, 128MB PC133 ram, Lilith Banshee PCI(Must get rid of it when I get more money :smile: ) and a SB Live! value and getting rid of ACPI fix my problem. Modem and soundcard would not work together no matter what PCI slot they were in or anything.

Now that I can use modem and the SB Live! value, is there any way to get the system of auto power off or do I have to live with it?

<b><font color=red>Facts speek for themselfs</b></font color=red>
 
G

Guest

Guest
Advanced Configuration and Power Interface

<b><font color=red>Facts speek for themselfs</b></font color=red>