Question Added Ram but can't set more mhz

Jul 3, 2019
4
0
10
0
Hello guys,

I recently bought a TeamGroup 2x4gb 3200mhz to add in my computer. These pair is the same that I already have, so now I have 16gb (4x4).

But now I cant set my ram to 3200mhz like I had before with 8Gb, When I restart and go to BIOS is at 2133mhz. What can I do?

Msi B350M Pro-VDH
Ryzen 5 2400g
Rx vega 56 8gb
Seasonic 520W Bronze
 

drivinfast247

Respectable
May 29, 2018
1,903
116
2,440
110
Yup! RAM is only guaranteed to work at specs when sold in kits. You mixed 2 different kits. Also, Ryzen is very picky when it comes to running 4 sticks at a time. You'll probably have to tweak settings for a while until you find the maximum stable speed they'll accept. It's doubtful you'll get to 3200mhz with that CPU and motherboard.
 
Reactions: herrwizo
Jul 3, 2019
4
0
10
0
Yup! RAM is only guaranteed to work at specs when sold in kits. You mixed 2 different kits. Also, Ryzen is very picky when it comes to running 4 sticks at a time. You'll probably have to tweak settings for a while until you find the maximum stable speed they'll accept. It's doubtful you'll get to 3200mhz with that CPU and motherboard.
With the 8gb I had ram with 3200mhz, I bought the same pair so now I have 4 equal sticks. It's not possible?
 
Jul 3, 2019
4
0
10
0
Possible yes, guaranteed no. Enter BIOS and try manually setting timings and voltage.
The problem is that I'm affraid of doing anything wrong, I tried almost every frequency and it returns to 2133mhz.
I don't understand that much about timings and voltage...
It's possible that the PSU is weak for the 4 sticks at 3200mhz? (combining with the other specs)
 

DMAN999

Respectable
Apr 17, 2019
1,822
461
1,890
65
You need to be using Windows 10 to use the newer BIOS versions, also you need to update your chipset drivers Before you update the BIOS.
AND set your BIOS to Optimized default settings Before you update.
Once you update the BIOS I would try setting the RAM to 2667 MHz and DRAM Voltage to 1.36 or 1.37 and see if that works.
If it does then you can try changing the speed to 2933 MHz and see if it will boot.
 

ASK THE COMMUNITY

TRENDING THREADS