Question Advice on installed Ram

shiftypowers1986

Prominent
Mar 26, 2019
4
0
510
0
Hi,

I have been having issues with my PC where certain games do not seem to be running as they should e.g. games like Bf5 have been stuttering and others do not feel right / smooth even with graphic tweaking.

My setup is as follows:

Intel(R) Core(TM) i5-9600K CPU @ 3.70GHz,
Z390-A PRO (MS-7B98) Motherboard
Geforce RTX 2070
Patriot Viper V4 16GB 3000MHz CL16

I thought originally maybe my CPU is bottlenecking as when I play a game and minimise to task manager my CPU is at 100%.

I tried OC Genie on my Motherboard and I have definitely seen benefits with my CPU and my temperatures are fine but when I looked at my memory it doesn't seem to be calibrated correctly in the Bios and CPU-Z?

I have attached screenshots of my Bios below and CPU-z to show what I mean. There is the option of turning XMP on on my motherboard that seems to put it back to 3000MHz instead of 2133MHZ its running at now?

Bios:

View: https://imgur.com/a/t9YxyRC


View: https://imgur.com/a/IfRQM2M


CPU-Z

View: https://imgur.com/a/qIIkb9N



Could anyone give me any advice? Also is it an issue have the Ram in Slot 2 and 4 instead of slot 1 and 3?

Thank you
 

maikutech

Distinguished
First check this video here then go to the link below it and read carefully.

1.
View: https://www.youtube.com/watch?v=NTWEzTV8B54&ab_channel=JayzTwoCents



2.
 

Lutfij

Titan
Moderator
Go into Advanced mode, then see if you can set XMP. If XMP doesn't work, you can manually input the timings, voltage and frequency in there and see if that helps alleviate the ram speed issue.
 

ASK THE COMMUNITY

TRENDING THREADS