Question After attempting to revert to older kernel version, Lenovo Thinkpad T480 goes to BIOS menu. Unable to start Ubuntu 18.04 normally

May 16, 2022
1
0
10
0
I have a 2019 Thinkpad T480 and have been running Ubuntu 18.04 with very few issues for a while now.

After a recent update, it started acting strangely. It would take an unusually long time loading on the Ubuntu screen with the 5 cycling dots. Then when it finally reached the profile select screen, the mouse and keyboard wouldn't function for another 5 minutes. And then when I fianlly logged in, there would either be no internet (wifi adaptor not detected), no sound (only Dummy Output in sound devices), or both.

After some trial and error, I found out that it could be an issue with the current kernel, 4.15.0-177-generic. Using the GRUB menu to roll it back to 4.15.0-176 seemed to solve my issues. So I tried to set that as the default kernel by editing GRUB_DEFAULT=0 to say GRUB_DEFAULT=2 in /etc/default/grub (because 2 was the index of the kernel version I needed) and that's when the real problems started.

Now when I start my machine, it shows the Lenovo logo, then a purple screen, then all the lights go out including power, then it shows the Lenovo logo again, and then it says "Entering setup..." and then goes to the BIOS boot menu. From there, I don't know how to get back to the GUI (or if I can). Restarting from the BIOS menu just cycles the same process over again. The only way to turn off the laptop that I can find is a hard reset by holding the power button.

Any suggestions for what to do would be greatly appreciated. I am still new to this, so please ask for clarificationof I'm not explaining this well!
 
I personally think bad kernel less likely. Have you checked for other issues:
  • Too little space left on storage partition(s)
  • HDD or SSD failure (check the S.M.A.R.T. data of the device)
  • RAM failure - check by using Memtest86+
 

Dave8671

Distinguished
Jan 1, 2014
849
20
19,415
133
When rolling back a kernel you need to remove the kernel that is activating up. I would manually remove it with

Code:
sudo apt purge linux image 4.15.0-177-generic.
Otherwise Ubuntu will load the newest kernel

I do suggest changing back to GRUB_DEFAULT=0 to see if the system boots into Ubuntu.

Once you boot the system hold SHIFT key (for BIOS users) or ESC (for UEFI users) the grub menu should pop up.

I think you should be able to select the kernel you want than. I not used Ubuntu a while.

One changes are done in grub run sudo update grub if you have not been.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS