After I installed my GPU I can't play games due to a huge dip in fps

bennicholass92

Prominent
Jan 27, 2018
15
0
510
0
I've been using integrated graphics for a while and finally got down to buying a gpu it's a 1060 3gb once I put it in I got a huge drop in fps.
 

COLGeek

Cybernaut
Moderator
Well, that is definitely a problem.

Power the system down and physically remove the 1060. Reconnect your display to the integrated video you were previously using.

Power on and let Windows detect the "new" hardware and re-install the video drivers.

Once fully installed, power the system down. Re-install the 1060 and connect your display to it. Restart the system, does Windows detect the now "new" video device and does it attempt to load drivers?
 

COLGeek

Cybernaut
Moderator
Did you install the Nvidia video drivers and connect your display to the GTX 1060 as well?

If yes to both, what are the specs for your system (list make/model of all components)? What are your CPU and GPU operating temperatures at idle and under load?
 

COLGeek

Cybernaut
Moderator
I only ask because there are many counterfeit GPUs on the market due to the recent demand for high-end GPUs for crypto-mining.

Install GPU-Z and see how it identifies the new video card.

https://www.techpowerup.com/gpuz/

What CPU, motherboard, and power supply are you using?
 

COLGeek

Cybernaut
Moderator

This is a very poor quality product. I would recommend you replace it with a quality brand in the near future (Seasonic, EVGA, Corsair, etc).

Regardless, it should power your current rig, if working properly.
 

COLGeek

Cybernaut
Moderator
Well, that is definitely a problem.

Power the system down and physically remove the 1060. Reconnect your display to the integrated video you were previously using.

Power on and let Windows detect the "new" hardware and re-install the video drivers.

Once fully installed, power the system down. Re-install the 1060 and connect your display to it. Restart the system, does Windows detect the now "new" video device and does it attempt to load drivers?
 

ASK THE COMMUNITY

TRENDING THREADS