[SOLVED] After new bios update for asus b450 f gaming no hdd found

Feb 2, 2021
9
0
10
0
After I updated my bios I had to reinstall windows on my nvme because it wouldn't find a boot device so I had to erase all my data which is fine, however my hdd is not able to be found even in bios. It is a 2tb seagate barracuda and It should still have everything downloaded on it. I have tried using a new sata cable the hdd disk is spinning, I'm also thinking about flashing back bios but I want to see if I can fix it first. (everything was fine before bios update)

mobo asus b450 f gaming
m.2 samsung 970 evo 500gb
hdd 2tb sea gate barracuda
 
Last edited:

Colif

Win 10 Master
Moderator
In the bios, what Sata mode are the drives in AHCI or RAID? Its on the Advanced menu . Page 3-15 of manual. As that is one way to hide it from windows but it should show in bios still.

did you try another port as suggested?
try another PC?
 
however my hdd is not able to be found even in bios. It is a 2tb seagate barracuda
I have tried using a new sata cable the hdd fan is spinning
Can you show screenshot from Disk Management and Windows Storage Spaces?
(upload screenshots to imgur.com and post link)

Note:
When the M.2_1 Socket 3 is operating in SATA or PCIE mode, SATA6G_5/6 ports will be disabled.
You may need to connect your HDD to a different sata port.

BTW - what is HDD fan?
 
Feb 2, 2021
9
0
10
0
Can you show screenshot from Disk Management and Windows Storage Spaces?
(upload screenshots to imgur.com and post link)

Note:
When the M.2_1 Socket 3 is operating in SATA or PCIE mode, SATA6G_5/6 ports will be disabled.
You may need to connect your HDD to a different sata port.

BTW - what is HDD fan?
my bad im really bad at terms i meant the disk and sorry not tonight I can send all the pictures tomorrow
 

Colif

Win 10 Master
Moderator
In the bios, what Sata mode are the drives in AHCI or RAID? Its on the Advanced menu . Page 3-15 of manual. As that is one way to hide it from windows but it should show in bios still.

did you try another port as suggested?
try another PC?
 
Feb 2, 2021
9
0
10
0
In the bios, what Sata mode are the drives in AHCI or RAID? Its on the Advanced menu . Page 3-15 of manual. As that is one way to hide it from windows but it should show in bios still.

did you try another port as suggested?
try another PC?
Thanks it was that I had it in AHCI and turned it to RAID then back to AHCI and i plugged in the SATA cable to a new port then it started working
 

ASK THE COMMUNITY

TRENDING THREADS