Question After turning on pc, CPU And DRAM red light flashing, no display, case fans not spinning, and power button isn’t working

Aug 25, 2021
3
0
10
0
In order to tell what’s fully going on, I will have to start from the beginning.

My cpu temp rises too high when I try to open up a game or do some medium load, reaching past 85-90c and then the pc restarts itself everytime. I tried to switch out my cpu cooler (hyper 212 evo) and saw that the heat sink was slanted and wasn’t giving full support, and put in my stock cpu fan that came with the cpu. I think I put in the ryzen stock cooler incorrectly or something and when I try to turn on my pc. Only the cpu fans, gpu fan, and psu fan Starts running. Although there is no display, case fans not turning on, and the power button isn’t working to shut down the system. Now I am stuck. I took off the cpu and put it back in multiple times and nothing changed. I hope you can try to start up my pc and mainly fix my cpu temp. It turns out one of screws of the cooler is not going entirely in and which made me full forced it in but it still wouldn’t budge. Probably cause of that, but idk. I took off the cmos battery and put it back in, nothing happened. When the pc starts, the motherboard starts flashing red lights on cpu and dram. I just got a new cpu and motherboard. Also switched out my ssd. Everything worked beforehand with all the components just the cpu temp was super high. My cpu is the ryzen 7 5800x . Motherboard is asrock b550 pro4. Please help on this. Been trying to fix my pc for days and I’m stressful as frick :) ask me for more information if needed and need a solution as fast as possible
 
In order to tell what’s fully going on, I will have to start from the beginning.

My cpu temp rises too high... tried to switch out my cpu cooler (hyper 212 evo) and saw that the heat sink was slanted and wasn’t giving full support, and put in my stock cpu fan that came with the cpu. I think I put in the ryzen stock cooler incorrectly or something ....
It sounds to me like you may have cross-threaded a screw into the backplate.It may not come out easily and you may need to get a new backplate so you can thread in another screw. If you're struggling at this too much you might have to get a friend who's done this a lot to help or maybe even take it to a shop to have them do it for you. Forcing it too much can damage hardware badly, worse even than cross-threading a screw into the backplate.
 
Aug 25, 2021
3
0
10
0
It sounds to me like you may have cross-threaded a screw into the backplate.It may not come out easily and you may need to get a new backplate so you can thread in another screw. If you're struggling at this too much you might have to get a friend who's done this a lot to help or maybe even take it to a shop to have them do it for you. Forcing it too much can damage hardware badly, worse even than cross-threading a screw into the backplate.
Yea I feel like I have put too much pressure on the cpu cooler when trying to install it. Although is there a reason why I can’t boot up my pc as I have mentioned in my original post
 
Yea I feel like I have put too much pressure on the cpu cooler when trying to install it. Although is there a reason why I can’t boot up my pc as I have mentioned in my original post
There's doubtless a reason...one COULD be if the cooler is not making contact to the CPU. When that happens the CPU flashes to an extremely high temp so it just shuts down instantly. There are countless other possibilities but to find out anything you first have to get a cooler properly attached and tightened, with thermal compound.
 
Aug 25, 2021
3
0
10
0
There's doubtless a reason...one COULD be if the cooler is not making contact to the CPU. When that happens the CPU flashes to an extremely high temp so it just shuts down instantly. There are countless other possibilities but to find out anything you first have to get a cooler properly attached and tightened, with thermal compound.
No the pc doesn’t turn off, the fans still run, and there is no way I can turn it off since the power button isn’t even working. I even just put my cooler on top of my cpu without screwing it in and nothing still happened. I hope nothing happened to my cpu, I beg
 

ASK THE COMMUNITY

TRENDING THREADS