Question After updating bios my pc does not detect my nvme with my windows on it

spiligen1

Reputable
Nov 18, 2017
9
0
4,510
0
So i succesfully updated my bios since it was very old, but when i started the computer up i got bsod error 0x00000e. When i checked my boot order my ssd with windows was gone.

I have no idea what to do

Specs:
Ryzen 3700x
X470 Asrock taichi ultimate
x62 kraken cooler
EVGA RTX 2080
Intel 660p 1tb nvme ssd (the one that my pc cant find and has windows)
Intel 660p 2tb nvme ssd
32 gb Corsair Vengeance RGB PRO DDR4 3200MHz
EVGA SuperNOVA 750 GM
Windows 10 pro
 
Last edited:

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and Windows OS information.

Motherboard?

As a general thought the bios update probably reverted to some default settings.

Also, take a look at the motherboard's User Manual: check SATA port assignments - there may be a conflict.
 

spiligen1

Reputable
Nov 18, 2017
9
0
4,510
0
Update your post to include full system hardware specs and Windows OS information.

Motherboard?

As a general thought the bios update probably reverted to some default settings.

Also, take a look at the motherboard's User Manual: check SATA port assignments - there may be a conflict.
Thanks for your help.

I could not find the SATA port assignments in the manual and as i was fiddling with my computer (changing the 2 nvme position around and then back to original position) it suddenly decided to work.

This is of course not really the best outcome, since i dont know what was wrong

Thanks again.
 

Satan-IR

Distinguished
Ambassador
Sometimes some BIOSes do weird stuff and there's a glitch which is resolved with a power cycle or unplugging and repluggin a component into a slot. Or as Ralston said a setting might revert back to default.

Keep an eye on the relative performance and also health of the drives and if all is OK I would say you have nothing to worry about.
 
Mar 16, 2022
5
1
15
0
This just happened with my NVMEs. I reset the CMOS and then updated the bios and it won't boot into the nvme. I decided to try and reinstall windows and it said it was unable to do it on the NVMEs. I'm going to try and reseat those components.
 

ASK THE COMMUNITY