Question after upgrading my storage to a 1tb m.2 i cannot install my gpu drivers, my pc starts boot looping and requires a fresh windows install.

Oct 25, 2021
2
0
10
0
I bought myself a new 1TB m.2 SSD (crucial p2), and I installed windows fresh onto the drive after formatting all of the drives I already had connected to my pc (a 240 GB SSD and a 1 TB HDD)
my pc ran just fine for a few hours (i was installing all my games and playing valorant + league of legends) until I realized I had forgotten to install Nvidia GeForce and update my drivers. so I tried to install them and the download completed just fine but when I try to install it, I just get a black screen then my computer reboots and then boot loops. every time this happens I have to reinstall windows as nothing that I was doing would stop it from boot looping.
I have tried taking out my m.2 and just trying to fresh install windows onto both my hard drive and smaller SSD separately but the same thing happens when I go to update my drivers. I have run windows memory diagnostic with no errors and honestly have no clue what to do next. any help would be hugely appreciated.
my specs are,
ASUS GeForce GTX 1060 3GB Dual-Fan OC Edition
AMD Ryzen 5 3600 6 Core
ASRock B450 Steel Legend ATX motherboard
Corsair Vengeance LPX 16GB RAM 2 x 8GB
 

EridanusSV

Notable
Aug 16, 2020
347
44
940
67
Hi tonksy166,

From what I've gathered, your GPU is outputting pixels -- that you can see your Win GUI just fine.

I heavily suggest installing your M2 drivers. Install that on main drive and get that driver updated.

Afterwards, download and run DDU to clean up everything Nvidia related in your system. If none of these helps, please reinstall or reset your windows and immediately install GPU Drivers & M2 drivers.
 

ASK THE COMMUNITY

TRENDING THREADS