Agility 3 - IDE to AHCI

Status
Not open for further replies.

iamchiwi

Distinguished
Nov 9, 2011
8
0
18,510
0
It is recommended that SSD should be using AHCI.

I have a Gigabyte GA-Z68XP-UD4 in which I have a OCZ Agility 3 120gb SSD as a boot drive, Velociraptor 160GB for apps plus 1tb drive and 2tb drive for data. I have by ignorance installed my SSD on one of the eSATA3 6 gb/s ports as IDE. There are 2 parameters in the F5 BIOS for the mobo that i can change IDE to AHCI. Which one do I change "PCH SATA Control Mode" (does this parameter affect all the drives?) or "eSATA 3 Ctrl Mode" or do I change both?

Also if I make this change, will I lose my data on the drives?

Before I make this BIOS change I have go into the registry to make a driver change from 3 to 0 is this correct?

Yes... I will do a backup, just in case.
 

Dougie Fresh

Distinguished
Jan 3, 2010
545
0
19,060
36
Before you make the BIOS change, you want to make the change in Windows. Otherwise, you system will likely not boot with the BIOS in AHCI mode and Windows in IDE mode.

The easiest way to make the change in Windows 7 is to do this:
http://support.microsoft.com/kb/922976

Run the FixIt in that KB article.

Reboot, make the BIOS change (sorry I dont know the answer -- likely the former is for the SATA II ports, the latter for SATA III and there are just two different controllers), save changes & exit. Windows will come up, install a new driver, ask you to restart and after that restart you're good.
 

iamchiwi

Distinguished
Nov 9, 2011
8
0
18,510
0
The latest firmware for the A3 SSD is 2.15, I'm on 2.11. I'm also having inconsistent boot ups where my led hdd light will stay ON and i do not get a clean boot (clean boot is only achieved after several attempts). Do you think think this boot issue i am having is firmware or AHCI related?
 

hunuok

Distinguished
Jul 4, 2009
522
0
19,060
28
Do you think think this boot issue i am having is firmware or AHCI related?
I would say both, but more due to AHCI.

If you change to AHCI mode + enable hot swapping in BIOS (hit "del" on power up>SATA config), you may cause instability issues.

I made the same mistake.

To make sure, I did a clean install anyway.

To update firmware from 2.11 to 2.15, OCZ Toolbox will not update on a Windows installed drive.

If you do not want to clean install, you can do a Linux install:

http://www.ocztechnologyforum.com/forum/showthread.php?89670-Bootable-Tools-for-OCZ-SandForce-Driven-SSD-s

After updating to 2.15, I found the system to be more reliable.
 

iamchiwi

Distinguished
Nov 9, 2011
8
0
18,510
0
I intend to attach the A3 SSD as another drive on another system to do the firmware update. Which do you suggest i do first; firmware or AHCI? After this exercise i might have to create dual boot system.
 

iamchiwi

Distinguished
Nov 9, 2011
8
0
18,510
0
Thanks a lot so far for all your help guys....

+ enable hot swapping in BIOS (hit "del" on power up>SATA config), you may cause instability issues.
I am trying to understand what you are saying here, doesn't enabling AHCI in BIOS also enables hot swapping as well? perhaps I have skipped/misunderstood a few parameters in the SATA section of the BIOS.

Please expand on what you are trying to tell me.
 

hunuok

Distinguished
Jul 4, 2009
522
0
19,060
28
AFAIK, enabling AHCI mode does not automatically enable Hot Swapping (at least on my motherboard).

There should be an option to enable/disable Hot Swapping in the same menu as enabling AHCI.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
N Storage 0

Similar threads


ASK THE COMMUNITY