Question AIO Corsair device not detected after firmware update

ShadowRD

Reputable
May 3, 2016
92
6
4,645
1
Yesterday after a firmware from iCUE software, my h100i pro turn off the lights and ask for restart, after that all when down hill.

The software do not detect the device, the RGB lights keeps off.

I tried uninstalling everything from device manager , including iCUE software, installing everything again, restart corsair services, desconnecting usb ports and sata cables like 3 times, unistalling every RGB controller on my computer, installing a older version of iCUE and nothing.

The only thing i dont know if i could rolling back the firmware if that could help some way

Fans keeps spinning but i dont have any control of them, not even on bios

 
Last edited:
How is your cpu temp?

Check in device manager down in the usb devices for the corsair usb.
On 1 of my units after a update,
that usb driver needed to be enabled again.

Did the Corsair unistall ask if you wanted to remove the config files?
You can also use Ccleaner to help get leftovers.

As long as your temp is good you could try rerunning the Corsair software you used to install it and remove the software again to try triggering the remove config removal.
Then reinstall the software then reboot after installation.

So use the corsair software installer (if you don't have it still installed.)

Then run corsair again this time removing
Then reinstall and shutdown and reboot.

I have also had to unplug the 9pin usb cable from mobo and move to a different header
While the pc is powered up.
Why I can't tell you but it worked.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS