Question Alienware 15R3 FPS drops and stuttering

Dec 9, 2018
8
0
10
0
I got an Alienware 15 R 3 , 1070 8 GB, i7 7700 Cpu
The first time I got the laptop Temps were below 85, Got a stable performance.. Ever since I updated bios from 1.0.5 to newer versions (1.2.5)(1.7.0 was even worse got constant drops) games started dropping, Support said I had to replace motherboard but I was sure it wasn't the problem , My Laptop was bought from a different country so I don't have warranty..
I gave it to a Dell authorised centre to replace bios chip and downgrade it as Intel locked the downgrades below 1.2.5. Performance went back to normal and I didn't have fps drops .. Few weeks back my motherboard was dead and I paid and got it replaced , This default version is 1.2.4 and I'm getting the same FPS drops
Csgo Check out the video

Temps are going upto 97 , Trust me every technician tells that it's normal for a high end gaming laptop . Plus I didn't have the issue when I downgraded to bios 1.0.5 ( I had the same temperature around 97-100)

So what do I do , I'm out warranty and Dell suport won't help me
All drivers are updated Properly, Os is also upto date ..
Should I Upgrade my bios to latest 1.7.0 ? I'm afraid it will make my fps drops even badder !
What should I do?
 
Perhaps Intel's XTU will allow you to lower the single and/or core clock speeds by 100-200 MHz, reducing any throttling that may be occurring....

Or, max out your res/and quality settings to try to shift some load to the GPU...or, for games that allow it, cap your fps to 60 for 60 Hz refresh which helps eliminate the scenario of a CPU trying to max out a GPU it can't keep up with....
 
Dec 9, 2018
8
0
10
0
Should I Upgrade my bios to latest or no?
Last time I did it was even worse..
But now it's a new motherboard.. Since temps are high should I replace my heatsink ?
I really don't think it's throttling because I had this exact same temperatures but no fps drops when I had my mother board on 1.0.5
 

ASK THE COMMUNITY

TRENDING THREADS