Question Alienware fx no longer functioning after latest windows update

Oct 11, 2019
2
0
10
0
So after yesterdays update (10/11/2019) I have found myself completely unable to turn off alienware fx.

The section of the command centre dedicated to the rgb displays only a black screen and upon exiting it I get the error message":

"System.Management.ManagementException: Not found"

I have tried multiple times to reinstall the command centre, making sure each time to delete each folder in appdata and programfiles as well as deleting the folders in regedit and using the uninstall service but upon reinstallation (and on startup with command centre installed), I get the message:

"System.NullReferenceException: Object reference not set to an instance of an object"
 

Colif

Win 10 Master
Moderator
What version of the Alienware fx are you using?
What model alienware is it? (I assume they have different models per year)

I have a friend with an alienware and he already hesitant based on your post

I looked already and couldn't see anything about that particular update (KB4517389) causing any problems with alienware but it could be too soon.

unless it was this one and it got carried away - https://support.microsoft.com/en-au/help/890830/remove-specific-prevalent-malware-with-windows-malicious-software-remo
 
Oct 11, 2019
2
0
10
0
It's an alienware 15 r2, as for the version of Alienware fx, I'm not quite sure what you mean.
If you are talking about command centre then I have tried both the latest version from the Microsoft store and the laptop version which I originally had (can be found under the dell drivers for alienware 15r2).

Also I see 3 updates that have happened between the 10th and 11th. The one you mentioned as well as (KB4515871) and (KB4521863).
From doing lots of digging I have seen people mention a connection between alienfx failing and .Net framework, but I don't really have much knowledge on the matter.
 

gardenman

Admirable
Herald
I'm the friend with the Alienware. I updated today and don't have any problems. My Alienware is older and so is my software, not to mention it's a different model. (Alienware Aurora 2009/2010-ish).

What I usually do when I have troubles from Alienware Command Center or any of it's tools (FX, ThermalControls, etc) is:
  • Look for an older version
  • Look for a .NET troubleshooter/repair tool
  • Uninstall any recent .NET updates
Microsoft .NET Framework Repair Tool :
https://www.microsoft.com/en-us/download/details.aspx?id=30135

This likely won't help you, but I believe this is the file info on the version that I'm currently using:

Alienware Command Center Application View details
App_DT_AWCC_W7_X04_Setup_TD4C0_ZPE.exe | Hard-Drive (65 MB)
Application | Release date 7/9/2012 | Last Updated 10/4/2013 | Optional
Version 2.8.9.0,A02-00
 

ASK THE COMMUNITY

TRENDING THREADS