All Games Micro-stuttering

Status
Not open for further replies.

DrGreen

Reputable
Jan 4, 2016
160
0
4,760
26
I was playing Fallout 4 yesterday with no issues. I turn my PC on today, open Fallout, and instantly noticed microstuttering whenever I moved my character with WASD. I started googling fixes for the stuttering, which nothing worked so far.

I then tested Alien Isolation, Bioshock Infinite (and the bench marking software AVG: 140fps max settings) which all had microstuttering roughly 2 stutters per second. But I have no FPS drops. The PC is roughly 5 months old and the temps are fine.

CPU - Intel i5-4460

Video Card - Asus Strix GTX 970

Motherboard - Asus Sabertooth Z87

Memory - 8GB HyperX DDR3

Storage - Samsung 850 Evo 250GB SSD / WD Blue 1TB Desktop HDD

Windows 10

I've checked for driver updates but they're up to date.
 
G

Guest

Guest
Make sure that NV panel "Manage 3D setting(s) Global" are set to the following if not already:

Multi-Display: Single (unless using multi-displays)
Pwr Mgt Mode: Prefer Max Performance
Preferred refresh rate: Highest Avail

Sometimes, these settings are default to lower settings that can affect GPU performance... This suggestion is not a guarantee fix, but something to look at.

I had issues with my single-GTX 970 (at the time) which was like yours along with low FPS and adjusted these settings as I noted above and my issue was resolved immediately.

Good luck!

 

DrGreen

Reputable
Jan 4, 2016
160
0
4,760
26
@vacavalier I tried these settings (unable to find Preferred refresh rate) and I'm still getting the micro stuttering. But I do believe this helped a bit with performance.

I'm going to re-roll my GPU drivers and reinstall them.

Edit: Reinstalling drivers did not help.
 
G

Guest

Guest
The only thing I can think of, is those games you are playing, might be reaching beyond the 3.5 GB of VRAM of causing the micros-stutter, but might not be in all cases.

Those games are/can be demanding when the visuals are cranked up, especially depending on what rez monitor you have. I would try dropping some of the advanced-graphic settings a notch or two and see what effect it has.

Also, what rez is your monitor? Is your 970 OC'd? If so, another option to look at is dialing it back and checking those results.
 

DrGreen

Reputable
Jan 4, 2016
160
0
4,760
26
1080p. My GPU isn't OC'd. I tried lowering the settings & I still get stuttering, but I always have constant 60 fps, and I've tried disabling v-sync.

I have to play at a lower resolution and windowed borderless, the stuttering is still there, but I really have to look for it.
 
G

Guest

Guest
I've seen some articles online relating to this and SSD/HDD causing the microstutter somehow, but seems to be a rarity... How old is the card? Reason for asking is, RMA/return may be required.
 

DrGreen

Reputable
Jan 4, 2016
160
0
4,760
26
Well.... I just unplugged my HDMI cord and re-plugged it and there is no more micro stuttering....

Could anyone explain how this is possible?

I feel stupid... but it doesn't make sense.
 
G

Guest

Guest
I just read something... I'm not sure if it will work or not, if it doesn't you can always return the setting back. In NV Panel "Manage 3d Settings" near the bottom, there is a setting labeled "Threaded Optimization". Set it to "Off" then apply and see what results you have. It "should" provide for a smoother frame-rate.

Let me know...

Edit: Default setting is "Auto"
 
G

Guest

Guest
Reseating cables, loose connectivity. It happens even inside of rigs, when nothing is being touched or moved...
 

DrGreen

Reputable
Jan 4, 2016
160
0
4,760
26
I just didn't think that microstuttering would be caused by my HDMI cable, I assumed it would be a hardware/driver issue.

@vacavlier, the settings you've told me to put on in the 3d settings has increased my fps drastically, I was noticing fps drops in FO4 down to 50 fps at some points, but I now never drop below 60fps on all Ultra settings, even God rays, in a massive battle... Thanks.
 

Mattp2017

Respectable
Jan 25, 2017
342
1
1,865
31


I would leave power management on global to adaptive and set it to maximum performance in the actual games settings to save power consumption.

 
Jan 2, 2019
1
0
10
0


Look I'm really sorry to necro this thread, but I just want to thank DrGreen.
The HDMI solution? After hours of being stumped and literally facto resetting my PC, this hidden-in-plain-sight trick helped me. Seriously Green, thank you. You've literally saved me thousands of dollars.
 
Mar 8, 2019
1
0
10
0
Well.... I just unplugged my HDMI cord and re-plugged it and there is no more micro stuttering....

Could anyone explain how this is possible?

I feel stupid... but it doesn't make sense.
I can't believe this solved my issue as well.
I re-plugged my DisplayPort cable to another slot and the micro stutter is GONE.

Tried everything from adjusting fan speeds, over- and underclocking to changing game settings.

Thank you.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS