Question All my games suffer from micro stutters / hitching

Feb 19, 2021
4
0
10
0
So i built a PC June 2020 all games were running smooth and then out of nowhere around November 2020 all my games started have a micro stutters but my FPS's dont drop when it hitches. Temps are also fine when playing games.
PC Specs:
CPU - Ryzen 5 3600x
GPU - RTX 2070 Super
PSU - Gigabyte B700H ATX POWER SUPPLY
RAM - Corsair Vengeance RGB PRO 16 GB (2 x 8 GB) DDR4 3200 MHz
SSD - Integral M Series 256GB NVMe M.2 Internal SSD, Up To 2000MB/s Read 1200MB/s Write
HDD - Seagate 3.5 Inch 2 TB BarraCuda Internal Hard Drive
Motherboard - b450 gaming pro carbon ac
Cpu Cooler - Corsair Hydro 100i RGB Platinum, Hydro Series, 240 mm Radiator
Monitor - Alienware AW2521HF 25 Inch Gaming Monitor (Freesync is on, Fps Settings on Extreme)
Second Monitor - Some Benq 60hz

Here is two benchmarks first one is without an Overclock the second is with a minor OC on my GPU.
https://www.userbenchmark.com/UserRun/40044727

https://www.userbenchmark.com/UserRun/40045127

A few things ive already tried -
Reset my PC to factory and it automatically installed a fresh windows, I have Xmp profile active, also set my Pci_e1 max link speed to Gen3 in my Bios, i have added a Cached Memory deleter which removes all cached memory every 5 mins, i have game bar disabled, also ive tested games on both my SSD and HDD and same issues continue, tried out different ram sticks didnt fix anything, redone the thermal paste on my cooler multiple times, my cpu pins are not bent or anything. Also used a different Display Port wire no fix. I have also tried many other things like chnaging the affinty on some games and unchecking core0 on cpu evern set priority to games on high. Even used CCleaner and Malwarebytes no isses there. Also tried Razer Cortex. If anyone has any ideas on how to fix this issue let me know please, cuz i personally after everything ive tested im thinking its a software issue i just cant pinpoint or a setting on my Bios which i need to change. Also ive tried reinstalling all my drivers, downloaded everything from Nvidea and MSI for my Motherboad. Also ended up using Snappy Driver Installer ust incase i forgot any drivers.
Also when i used to run OBS to record every now and again my FPS's would drop and stuttering became a lot more frequent.
Other than gaming my PC runs perfectly, no hitching when watching movies, streams and etc.

Any help would be greatly appreciated, thank you!
 
Last edited:

Vic 40

Titan
Ambassador
Have the latest chipset drivers from here?
AMD Drivers and Support for Radeon, Radeon Pro, FirePro, APU, CPU, Ryzen, desktops, laptops

Tried the extra options within windows for energy management? Those added by the AMD drivers and meant for Ryzen.

Not likely the issue right now (psu), but tried using both pcie cables to power the gpu? Not just one cable=two connectors.

Something else, looking at the userbenchmarks do you not use the latest bios so update that to latest as well.
 
Feb 19, 2021
4
0
10
0
Have the latest chipset drivers from here?
AMD Drivers and Support for Radeon, Radeon Pro, FirePro, APU, CPU, Ryzen, desktops, laptops

Tried the extra options within windows for energy management? Those added by the AMD drivers and meant for Ryzen.

Not likely the issue right now (psu), but tried using both pcie cables to power the gpu? Not just one cable=two connectors.

Something else, looking at the userbenchmarks do you not use the latest bios so update that to latest as well.
Thank you for the response, i already downloaded the chipset driver but it doesnt let me download the raid driver and install.
I just tried the Amd power options on high and still same problems.
I got 2 connecters currently.
I also just updated the Bios and same problem persists.
 
Feb 19, 2021
4
0
10
0
Raid driver isn't really necesary so no problem there. Did you look at the LAN driver however?

Games are on the hdd?
I have i did a clean install of it tye other day and they are on HDD but i tried my games on SSD too and problem still persisted
 
Feb 23, 2021
1
0
10
0
Hey, I literally have the same issue... Tried most of the things you said, cleaned installed windows from scratch, even bought extra SSD so I do not even use HDD anymore. This problem have been bugging me for couple of months now, I tried everything from using DDU, Using standby cleaning list , to running stress/benchmark tests, but any game I play every 30seconds or so I get a small hiccup. On the actual benchmarks and tests everything seems to be fine. I play a lot of league of legends and it is so frustrating when it happens. The gpu and cpu load during LOL's game is around 30-40% and the temps are always low.
Also my specs are really close to yours:

CPU - Ryzen 5 3600x
GPU - RTX 2070 Super Gigabyte OC
PSU - Corsair RM750x
RAM - Corsair Vengeance RGB PRO 16 GB (2 x 8 GB) DDR4 3600 MHz
SSD - Samsung evo 970pro and samsung 860
Motherboard - Gigabyte x570
Cpu Cooler - stock
Monitor -MSI MPG27CQ 144hz

What brand GPU are you using? Maybe just maybe it might be our GPU's I am not sure...
 
Feb 19, 2021
4
0
10
0
Hey, I literally have the same issue... Tried most of the things you said, cleaned installed windows from scratch, even bought extra SSD so I do not even use HDD anymore. This problem have been bugging me for couple of months now, I tried everything from using DDU, Using standby cleaning list , to running stress/benchmark tests, but any game I play every 30seconds or so I get a small hiccup. On the actual benchmarks and tests everything seems to be fine. I play a lot of league of legends and it is so frustrating when it happens. The gpu and cpu load during LOL's game is around 30-40% and the temps are always low.
Also my specs are really close to yours:

CPU - Ryzen 5 3600x
GPU - RTX 2070 Super Gigabyte OC
PSU - Corsair RM750x
RAM - Corsair Vengeance RGB PRO 16 GB (2 x 8 GB) DDR4 3600 MHz
SSD - Samsung evo 970pro and samsung 860
Motherboard - Gigabyte x570
Cpu Cooler - stock
Monitor -MSI MPG27CQ 144hz

What brand GPU are you using? Maybe just maybe it might be our GPU's I am not sure...
hey sorry for late reply but mine is msi
 

fatehasfans

Honorable
Feb 24, 2016
22
1
10,515
0
hey sorry for late reply but mine is msi
I have the same issue - seems no one has a solution outside of the usual (drivers, hardware, bios and nvidia settings i.e. v-sync/cap FPS etc) . So many people now suffer from input lag and it's mainly in new/powerful systems. What I would trade for my old PC, thing ran like a dream and my mouse was precise and never any input lag. Now though I have the best of the best and my keyboard and mouse fail to register when I am clicking multiples times or in combination, mouse also feels a little floaty. Put up with it for a few years now so Im used to it but it's all but killed my competitive gaming.
 

The Dude

Distinguished
Feb 23, 2014
64
0
18,640
3
Hello, I'm not sure if this is against the forum rules, if it's the case then delete this post

I'm having the exact same problems on an Asus gaming laptop, I have an i5 7300HQ, GTX 1060 3GB, 8GB dual channel RAM and NVME SSD, so if you found a solution please share it

I have micro stutters in almost all games no matter what settings I used, the GPU usage drops to 0% for a split second then comes back to normal when the stutter happens, I first thought it's a VRAM or RAM issue, but just yesterday I tried Resident Evil 2 with 720p, everything on ultra low and 50% resolution scaling, the FPS reaches 200+ but there are micro stutters no matter what, even when I limit my FPS to 30 with those settings.
I've been only gaming on Switch for months now just because of these issues
 

ASK THE COMMUNITY

TRENDING THREADS