[SOLVED] All my USB ports stopped working at once

Jun 21, 2021
3
0
20
1
I was browsing my PC, everything was fine, then I noticed the keyboard was pressing random letters and I restarted my PC, once restarted, ALL of my USB ports stopped working or giving any power to any of my devices, so no rgb lights nothing, I have a wifi adapter and no more wifi also, I can’t do anything since mouse and keyboard wont work. I restarted multiple times, waited, even reset the CMOS battery, no cable appears to be loose inside, I’m now stuck in the bootloader asking for me to press F1, I’m out of options.. what the hell happened? Help.
 

hedwar2011

Distinguished
Dec 3, 2011
1,518
3
19,965
98
I'm assuming you probably have USB ports on the back of your PC (assuming this is a desktop). If so, plug just the keyboard in via USB on the inner-most port closest to the CPU. These ports are usually the native ports on a motherboard. Make sure that you aren't plugging it into the front ports on the chassis or on top (if you have them on top) as these are typically just a hub connected to the motherboard itself. Once you've done that, restart the PC again and see if it responds like that long enough to get you into Windows.

If you are able to get into Windows (Normal or Safe Mode), do the following:
  1. Go into Device Manager (however it is you get there)
  2. Expand Universal Serial Bus Adapters category
  3. Right click each of the USB Root Hubs (one at a time mind you)
  4. After right clicking, choose uninstall. The computer will think for a minute and it may prompt you to reboot. DO NOT reboot until you've removed all of them.
  5. Once you have all of them removed, reboot the computer.
  6. After the reboot, Windows should rebuild all the USB Root Hub drivers so it may take a minute. It is also best that nothing is plugged into those ports for the time being.
Once the process is finished, go ahead and try your device again.
 
Jun 21, 2021
3
0
20
1
Hey, thanks for trying to help, I have 8 USB ports total, 2 on the front, 6 in the back of the PC, all 8 are not working, but have been working forever. I just tried again, one by one, to plug the keyboard alone, to no avail :’(
 

lokibaelish

Reputable
Jul 15, 2018
17
0
4,510
0
Hey, thanks for trying to help, I have 8 USB ports total, 2 on the front, 6 in the back of the PC, all 8 are not working, but have been working forever. I just tried again, one by one, to plug the keyboard alone, to no avail :’(
Same happened to me this week? Did you get it fixed im currently looking for a new motherboard
 

ASK THE COMMUNITY