All the files that I download get corrupted.


Apr 12, 2007
Okay so this is my problem.

For a while I have been having some issues when it comes to downloading random stuff (say for instance drivers from Nvidia, to games, tv shows, movies, you name it.) when I download an ISO file, its corrupt and can't be mounted on any virtual CD/DVD Rom, when its a RAR file, it cant be extracted as it gives a CRC Error message saying that the volume is corrupt, same thing happens with EXE files.

The only way I have found that fixes the corrupted files is re-downloading the whole file again (if it is a RAR, just downloading the part that is corrupted.). However, I'm really getting ticked off at this problem; because I can't basically download anything without having to re-download countless times to see if this time I get the file right.

I have done some research myself and I found on some forum that tons of people were having these issues with ASUS boards, but that's not the case for me, since I have an Intel one.

Here are my computer specs:
Motherboard: Intel DG965SS.
Processor: Intel Core 2 Duo E6400.
RAM: 2x Supertalent 1gb DDR2 667 Mhz.
Video Card: MSI Nvidia Geforce 8800GT.

Back to the topic, in that forum one of the guys that was getting the same download problems as I am fixed it by replacing the Network Card, but I don't think that that's the case for me because its not only my computer getting these problems when downloading, as my brother has another model of Intel motherboard and a different video card. Another guy (one that had an ASUS board) fixed his issue this way:

"The problem was the ActiveArmor SNE (Secure Networking Engine) . Shut it off in the Forceware Network Access Manager (Start>Programs > NVIDIA Corporation > Netware Access Manager > Web-Based Interface)"

I tried looking for that even though I knew I was on an Intel board and found nothing.

Can anyone help me with this problem?

Thanks in advance.


Hi all, I am having the same problem as the OP.

Could it be a virus or malware that I got somehow?
All my sw is legit precisely to avoid this garbage.

This is very strange and poorly documented anywhere

This is my setup

i7 960 3.2Ghz OCed to 3.53Ghz
12 GB RAM Mushkin Redline 6,7,6,18, 72, T2
2x WD VelociRaptors 300GB
1x Toshiba 500 GB
Windows 7 64bit (running on 1 of the Raptors)
Nvidia 9800 GT

I doubt it's the RAM because I just switched from Corsair, and reinstalled the whole system.

Please someone help!

Hate to say it but I am pretty lost.




Apr 5, 2010
I have the same problem, and I found out the problem has to do with my router . I am currently using a windows 2008 server as a NAT. When I hook up one of my PC's directly to my modem, I no longer have corrupt downloads.

I am now using a different router and everything works fine!

Hopefully this helps for you as well.



Jun 19, 2012
hi ,
i am having the same problem but it says file is unknown or an unsupported file when i used poweriso and daemon disc tools?
r they corrupt or am i doing something wrong