Question All USB-hubs do not work on PC properly.

Jul 5, 2019
4
0
10
0
Hello. I have an alienware Alpha R2 PC. See specific specs here: https://topics-cdn.dell.com/pdf/alienware-steam-r2-console_setup-guide_en-us.pdf
the important stuff is below, and all USBs on this machine are 3.0 except for a hidden bottom port that is 2.0.

MY PC SPECS:
  • Intel(R) Core(TM) i76700T CPU @ 2.80 GHZ 2.80 GHz
  • 16.0 GB of DDR4 Ram.
  • Hooked to an Alienware Graphics Amplifier using a corsair 650 watt Power Supply and a AMD 5700XT Graphics card.
  • All involved hubs are USB 3.0.
The issue:
When using any USB hubs. and I mean any ( various were tested) devices initially seem normal for the first minute. Then during any amount of use, they either disconnect or hang on inputs. For example: I tested the keyboard in notepad by typing "sdf" repeatedly. It goes like this: "sdfsdfsdfsdfffffffffffffffffffffffffffsdfsdfsddddddddddddddd"
All the USB ports on the machine function properly in all other scenarios. All the devices do as well and were tested on multiple other PCs. The USB Hubs in question ALSO work on all other PCs including when paired with all devices that were used for testing. Even stranger, the USB Hub built into the board of the Alienware Graphics amp, (which hooks to the main PC via a proprietary cable and not USB) shows the exact same symptoms. One of the PCs I used for testing in my Wife's Alpha R2, with the exact same spec minus the graphics amp. For good measure I hooked her PC into my Graphic amp setup with all devices in question. Zero issues.


The steps I have taken so far:
  • Tested all devices including the hubs on multiple machines including the exact same machine owned by WIFE
  • Tested Wife's Machine in my setup with all my hardware. Zero issues for her.
  • Verified that me and her have all the exact same drivers down to the version numbers.
  • Uninstalled and reinstalled all USB everything in Device in Manager.
  • Tested without the graphics AMP.
  • Multiple Fresh Windows installs and driver version tests. ( even though clearly the ones I was using work on another machine )
  • Tried Powered USB Hubs as well, and Graphics amp built in hub ( which is powered)
  • Changed power settings and tested all of the above with USB Select suspend both on and off.
  • Tested changing the power settings to not allow windows to turn off the devices in device manager for each usb device and in multiple combinations.
  • Tested all hardware in all USB ports including the USB 2.0 port.
  • Manually flashed the Motherboard bios to the newest version as well as other Drivers being FULLY up to date.
  • Windows Updates.
For context, there has never been a time where external hubs worked. I never had a reason to use them until the last year, and this has been ongoing.


Essentially I am at wits end. I am unsure how to proceed and now suspect there is some small defect regarding my machine. ( Though I found now reports for it specifically regarding this issue. ) Currently my PC works just doing without one of my USB devices I used previously, but I am worried that it is a hardware issues and that do without is only a temporary fix.

Thanks to all who attempt to help.
 

ASK THE COMMUNITY

TRENDING THREADS