Question Alt key toggle?

Sep 23, 2019
6
0
10
0
Hello good people!
I want to start out by giving you some info on my system:

Laptop:

System Manufacturer: ASUSTeK COMPUTER INC.

System Model: X550LD

System Type: x64-based PC

BIOS Version: American Megatrends Inc. X550LD.306, 5/14/2014 [Might come in handy]

OS Name: Microsoft Windows 10 Pro

OS Version: 10.0.18362 N/A Build 18362

OS Manufacturer: Microsoft Corporation

OS Configuration: Standalone Workstation

OS Build Type: Multiprocessor Free

What happened:

This issue started to happen after pressing some weird key combination while playing a game.

At first I thought that my alt key died, and after having a LONG read of almost everything I could find on google about it I came to the conclusion that this was the issue. I later discovered that my alt gr key wasn't working anymore too. I read on a post that usually there are multiple keys wired together, so it seemed like the chip that controls those 2 keys suddently died for no apparent reason.

For the time being I decided to circumvent the problem and used my secondary mouse buttons for alt-tab and in the future replace the laptop's keyboard.

The Game:

All of this is relevant and will come into play later

The game which I was playing has a dodging mechanic that allows the user to dodge by pressing LSHIFT.

The game has a 3 second cooldown for the air dodge and 1 second cooldown for the ground dodge. The game speed is very fast and sometimes it happens to press the dodge button multiple times. (Hopefully you see where I'm going with this now.

The debugging:

Things tried:

Reboot windows

Change keyboard layout/language and input methods

Reset keyboard settings

Tried to play with sticky keys(it was disabled)

Tried booting on a portable version of linux - This one gave me the absolute certainty that the keys were broken somehow. So at this point I had no doubt my keyboard was broken.

The revelation:

While playing the game on another occasion after pressing alt-tab (I was still used to doing it as I use alt tab a LOT) it suddently worked. I then thought that the issue was solved and happily went back to playing knowing that my alt key wasn't broken.

As you can imagine, finding out that your key works after trying to boot with linux and still seeing that it doesn't work is.... to say the least suprising.

The real debugging:

As of right now I've figured out that there are 2 ways to reactivate the alt (notice!! sometimes only the alt key gets reactivated, leaving alt gr still deactivated)

The first one is by pressing shift a number of times?? (It doesn't seem like the number of times is consistent and I sometimes help myself by enabling the beeping when pressing modifier keys !!!!NOTICE THAT THIS WHOLE TIME STICKY KEYS/ANY OTHER KEYBOARD RELATED SETTINGS ARE DISABLED!!!!

The second way I figured out recently is pressing the alt key somewhere from 3 to a maximum of 7 times works, even tho not even this feels consistent.

This issue is extremely annoying as by playing the game I casually disable my alt key and it's very hard to reactivate, as I have to do it completely blind.

Note: By activating the beeping of modifier keys I've noticed 2 different things:

The first time I activate the beep for modifier keys I was getting a boop boop beep; after completing this sequence about 4 times the alt key would usually reactivate. [while pressing shift, I haven't tried other keys]

The second time I activated it I was only hearing boop beep repeatedly, thing that did NOT reactivate the alt key. [I tried pressing ctrl, alt, win key and shift this time and none of them worked]

Final notes:

I've noticed that a lot of users have this problem and NO manufacturer has yet proposed a solution for this other than replacing the keyboard so I'm making this post for further investigation and problem solving hoping that many other users having this problem could be helped.

Keep in mind that changing the operating system did not re-enable the key. That is why I have to deduce that something is modified at the BIOS or UEFI level.

I have uninstalled some software recently, and it seems that the key is stuck being "off". I cannot say exactly what did it, but some forums I read point to the wacom tablet driver I had installed. I was not able to get it running since.

And lastly I am sorry if I did not use the correct terminology for some things and for the spelling errors throughout the post. Thank you for going thorugh this massive wall of text :D
 

Lutfij

Titan
Moderator
In short, from what I've read in your thread, your keyboard is broken. On another note, you're on BIOS 306. The latest is 308 with 307 between the two. Also for a game that you've mentioned, you should be playing the game with a USB driven keyboard so replacing that keyboard is easier. Now, you need to disassemble the laptop just to get to the keyboard.
 
Sep 23, 2019
6
0
10
0
Answering kerberos, I've checked ease of access multiple times and everything is switched off, I mentioned that even after booting with linux from a live usb it didn't work.

Answering Lutfij: I am very sure that the keyboard isn't broken, for the very specific reason that the Alt key was getting reactivated when shift is pressed a certain amount of times: Not 5 so it's not sticky keys.

To add to that, there wasn't any sort of damage to the keyboard and every single other thread(There is a crazy quantity of posts similar to this regarding the alt key) and all of them are closed by saying:
Your keyboard is faulty. NO, it is not faulty if it can be deactivated and reactivated when a certain sequence is pressed. I am very curious why this happens because it seems to be something affecting the keyboard chipset(driver)?? As far as I know drivers are limited to os only, so there isn't any possible reason for which it wouldn't work on linux, so that is really weird to me.
 
Sep 23, 2019
6
0
10
0
so if u say sometimes it work and sometimes it doesnt, u may need to dissasemble it, there should be some drink residues or similar conductive stuffs...clean it up
I'm sorry, I don't think I was clear enough. The alt key works after a very specific key pattern is pressed. It does not work intermittently, it works perfectly after that sequence was pressed and when the sequence is pressed again it stops working.
I'm going to repeat my self in case it still wasn't clear enough.
After shift or alt(the key itself) is pressed multple times fast(something like 10 presses sequence) it works perfectly, when the sequence is pressed again, it stops working no matter what you do.
I don't know how to make it more clear.
 
Sep 23, 2019
6
0
10
0
I did some experiements and I found some interesting things:
  1. Keeping any key pressed gives a 26.9 keys/ second.
  2. Keeping pressed shift key gives 26.9 keys/second but drops to 8 when I press both and only both alt and alt gr keys(1 has no effect)
  3. rshift and lshift work perfectly on their own, BUT:
if both shifts are pressed at the same time one of them remains active according to passmark keyboard test. I went through the windows settings and all keyboard modification/ ease of access are OFF
if one of the shifts are pressed + alt + alt gr the other shift activates by itself and stays on.
Another thing that recently happened was that after testing all keys the caps lock and num lock leds were blinking in a sequence. It stopped after a bit of not touching the keyboard.
I have to mention here that this may be related to a small spillage for which I am responsible of.
Please note tho the spillage I am talking about happened around 1 week ago (this is waaaayyy after the alt problem which started around 2 months ago) and had basically no visible damage on the keyboard.
Also I'd like to thank you for pointing out my bios version was outdated and I went to the process of updating it and installing the atk drivers without any issues.
I am now running the following bios version:
BIOS Version/Date American Megatrends Inc. X550LD.308, 4/17/2019
Also I am sorry if I make my comments very long, but I try to be as explicit as possible and give as much information as possible to eventually be useful to other people having this issue, also thank you again for taking time to answer my post.
 
as u said leds blinking while pressing keys, it means some trace(s) is shorted, open it up and clean it

it should looks like this (usualy several layers)

ive had tons of spills over teh years and it always worked after cleaning, its just plastic, nothing to burn there
 
Sep 23, 2019
6
0
10
0
as u said leds blinking while pressing keys, it means some trace(s) is shorted, open it up and clean it

it should looks like this (usualy several layers)

ive had tons of spills over teh years and it always worked after cleaning, its just plastic, nothing to burn there
Oh right, I'm sorry. I should've mentioned that I opened it all up and cleaned it and left it to dry. (it is however a laptop integrated keyboard so I wasn't able to get all the way under the metal, hence the traces working wrong)
I did the power off, take power cord off and press power button for 30+ sec to drain any remaining current.
I haven't yet taken out the cmos battery but I don't think it would help at all. I am trying to figure out if I can "activate" the alt keys again and do some experiments.
 

ASK THE COMMUNITY

TRENDING THREADS