Question AM4 socket might be broken

Jun 10, 2019
3
0
10
0
Hello all!
Need some help regarding my CPU. I recently just built my first PC build and with my motherboard I keep getting a red light on the CPU debugging LED (got a MSI B450 gaming pro carbon ac) and no post. I RMA the CPU and got a replacement today. But the red LED on the motherboard for the CPU is still coming on. Not sure if the AM4 socket itself is the problem now?
I trouble shooted everything the first time and again but same problem :/
Everything else such as graphics card is turning on.
The CPU is a Ryzen 2600x
 

RealBeast

Titan
Moderator
Hello all!
Need some help regarding my CPU. I recently just built my first PC build and with my motherboard I keep getting a red light on the CPU debugging LED (got a MSI B450 gaming pro carbon ac) and no post. I RMA the CPU and got a replacement today. But the red LED on the motherboard for the CPU is still coming on. Not sure if the AM4 socket itself is the problem now?
I trouble shooted everything the first time and again but same problem :/
Everything else such as graphics card is turning on.
The CPU is a Ryzen 2600x
I would do a desktop build (like on a sheet of cardboard) to rule out a short to the case. Also, check the connection for both ends of your main and CPU power connectors to insure that they are firmly seated and that the cables visually look okay.

Also, list your other parts model numbers -- PSU, GPU, memory. Thanks
 

ASK THE COMMUNITY

TRENDING THREADS